zoj1586

 

 

QS Network

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network

In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:

 

A sample QS network, and QS A want to send a message.
Step 1. QS A sends message to QS B and QS C;
Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;
Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.

Input

The 1st line of the input contains an integer t which indicates the number of data sets.
From the second line there are t data sets.
In a single data set,the 1st line contains an interger n which indicates the number of QS.
The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.
In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.

 

Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.

Sample Input

1 3 10 20 30 0 100 200 100 0 300 200 300 0

Sample Output

370

 

#include <cstdio>
#include <cstring>
#define MAX 1000000

int Edge[1010][1010];	//邻接矩阵
int adapter[1010];		//每个QS喜欢的适配器价格
int lowcost[1010];		//充当prim算法中的2个数组(lowcost数组和nearvex数组)的作用
int t;	//测试数据的个数
int n;	//每个测试数据中QS的个数

void init( )
{
	int i, k;	//循环变量
	scanf( "%d", &n );	//读入QS的个数
	for( i = 0; i < n; i++ )
		scanf ( "%d", &adapter[i] );//读入每个QS喜欢的适配器价格
	for( i = 0; i < n; i++ )	//利用输入数据构造邻接矩阵
	{
		for( k = 0; k < n; k++ )
		{
			scanf( "%d", &Edge[i][k] );
			if( i == k )  Edge[i][k] = MAX;
			else  Edge[i][k] += adapter[i] + adapter[k];
		}
	}
	memset( lowcost, 0, sizeof ( lowcost ) );
}

void prim( )
{
	int i, k;	//循环变量
	int sum = 0;//sum为最终求得的最小生成树的权值
	lowcost[0] = -1;	//从顶点0开始构造最小生成树
	for( i = 1; i < n; i ++ )
		lowcost[i] = Edge[0][i];
	for( i = 1; i < n; i++ )	//把其他n-1个顶点扩展到生成树当中
	{
		int min = MAX, j;
		for( k = 0; k < n; k++ )	//找到当前可用的权值最小的边
		{
			if( lowcost[k] != -1  &&  lowcost[k] < min )
			{
				j = k;
				min = lowcost[k];
			}
		}
		sum += min;
		lowcost[j] = -1;	//把顶点j扩展进来
		for( k = 0; k < n; k ++ )
		{
			if( Edge[j][k] < lowcost[k] )
				lowcost[k] = Edge[j][k];
		}
	}
	printf( "%d\n", sum );
}

int main( )
{
	scanf ( "%d", &t );	//测试数据的个数
	for ( int i = 0; i < t; i ++ )
	{
		init( );
		prim( );
	}
	return 0;
}

 

posted @ 2013-05-04 15:32  哥的笑百度不到  阅读(165)  评论(0编辑  收藏  举报