hud 5562 Clarke and food (水题)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 431    Accepted Submission(s): 245

Problem Description
Clarke is a patient with multiple personality disorder. One day, Clarke turned into a cook, was shopping for food. 
Clarke has bought n food. The volume of the ith food is vi. Now Clarke has a pack with volume V. He wants to carry food as much as possible. Tell him the maxmium number he can brought with this pack.
 
Input
The first line contains an integer T(1T10), the number of the test cases.
For each test case: 
The first line contains two integers n,V(1n105,1V109)
The second line contains n integers, the ith integer denotes vi(1vi109).
 
Output
For each test case, print a line with an integer which denotes the answer.
 
Sample Input
1 3 5 1 3 4
 
Sample Output
2 Hint: We can carry 1 and 3, the total volume of them is 5.
 
简单的贪心,把元素排好序以后往后加,等到背包装满之后结束。
注意不要用c++进行输入输出,否则会超时。
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>

int cmp(const void *a, const void *b){
    return *(int *)a - *(int *)b;
}

int main(){
    int T;
    scanf("%d", &T);
    while(T--){
        int n, v;
        scanf("%d%d", &n, &v);
        int i;
        int num[100005];
        for(i = 0; i < n; i++) scanf("%d", &num[i]);
        qsort(num, n, sizeof(int), cmp);  //排序
        int sum = 0;
        int count = 0;
        for(i = 0; i < n; i++){
            if(sum + num[i] > v) break;  //贪心
            sum += num[i];
            count++;
        }
        printf("%d\n", count);
    }
    return 0;
}
 
 
 
posted @ 2015-11-16 15:16  shadow_C  阅读(148)  评论(0编辑  收藏  举报