HDOJ 1576 A/B


数论水题。。。

A/B

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1280    Accepted Submission(s): 981


Problem Description
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
 

Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
 

Output
对应每组数据输出(A/B)%9973。
 

Sample Input
21000 53
87 123456789
 

Sample Output
7922
6060
 

Author
xhd
 

Source
 

Recommend
linle
 
 


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        long long int b,n,x;
        scanf("%I64d%I64d",&n,&b);
        for(x=0;x<9973;x++)
        {
            if((b*x-n)%9973==0)
                break;
        }
        printf("%I64d\n",x);
    }
    return 0;
}
* This source code was highlighted by YcdoiT. ( style: Codeblocks )


posted @ 2013-10-04 00:22  码代码的猿猿  阅读(236)  评论(0编辑  收藏  举报