03xxxx323(陈XX:交换机配置(2)--跨交换机VLAN)

 

《计算机网络》上机实验报告

                                                                                               

专业和班级

 

成绩

 

姓名

陈XX

学号

03xxxx323

课程名称

计算机网络

实验名称

交换机配置(2)--跨交换机VLAN

  1. 简述数据链路层的主要功能及服务。
  2. 认识交换机的概念、特点和功能。
  3. 掌握网络拓扑图的设计过程。
  4. 初步掌握跨交换机的VLAN配置。

简要解释下面网络术语。

1.简述数据链路层的主要功能及服务。

答:

主要功能:

成帜(帜同步)、差错控制、 流量控制、链路管理、MAC寻址、区分数据与控制信息、透明传输等七大功能。

数据链路层最基本的服务是将源计算机网络层来的数据可靠的专输到相邻节点的目标计算机的网络层。为达到这一目的,数据链路层必须具备一系列相应的功能,但主要功能是前五种。

服务:数据链路层的设计目标就是为网络层提供各种需要的服务。实际的服务随系统的不同而不同,但是一般情况下,数据链路层会向网络层提供以下三种类型的服务:①无确认的无连接服务;②有确认的无连接服务;③有确认的面向连接服务。

①  无确认的无连接服务:是指源计算机向目标计算机发送独立的帧,目标计算机并不对这些帧进行确认。这种服务,事先无需建立逻辑连接,事后也不用解释逻辑连接。正因如此,如果由于线路上的原因造成某一帧的数据丢失,则数据链路层并不会检测到这样的丢失帧,也不会恢复这些帧。出现这种情况的后果是可想而知的,当然在错误率很低,或者对数据的完整性要求不高的情况下(如话音数据),这样的服务还是非常有用的,因为这样简单的错误可以交给OSI上面的各层来恢复。如大多数局域网在数据链路层所采用的服务也是无确认的无连接服务。

②  有确认的无连接服务:为了解决以上“无确认的无连接服务”的不足,提高数据传输的可 靠性,引入了“有确认的无连接服务”。在这种连接服务中,源主 机数据链路层必须对每个发送的数据帽进行编号,目的主机数据链 路层也必须对每个接收的数据帐进行确认。如果源主机数据链路层在规定的时间内未接收到所发送的数据帜的确认,那么它需要重发 该帜。 这样发送方知道每一帜是否正确地到达对方。这类服务主要用 于不可靠信道,如无线通信系统。它与下面将要介绍的“有确认的 面向连接服务”的不同之处在于它不需要在帜传输之前建立数据链 路,也不要在在帜传输结束后释放数据链路。

③  有确认的面向连接服务:大多数数据链路层都采用向网络层提供面向连接确认服务。利用这种服务,源计算机和目标计算机在传输数据之前需要先建立一个连接,该连接上发送的每一帜也都被编号,数据链路层保证每一帜都会被接收到。而且它还保证每一帜只被按正常顺序接收一次。这也正是面向连接服务与前面介绍的“有确认无连接服务”的区别,在无连接有确认的服务中,在没有检测到确认时,系统会认为对方没收到,于是会重发数据,而由于是无连接的,所以这样的数据可能 会复发多次,对方也可能接收多次,造成数据错误。这种服务类型 存在3个阶段,即:数据链路建立、数据传输、数据链路释放阶段。每个被传输的库都被编号,以确保帽传输的内容与顺序的正确性。大多数广域网的通信子网的数据链路层采用面向连接确认服

2.简述VLAN的概念、作用和分类。

答:

概念:

VLAN(Virtual Local Area Network)即虚拟局域网,是将一个物理的LAN在逻辑上划分成多个广播域的通信技术。VLAN内的主机间可以直接通信,而VLAN间不能直接通信,从而将广播报文限制在一个VLAN内。

作用:

①  广播风暴防范:限制网络上的广播,将网络划分为多个VLAN可减少参与广播风暴的设备数量。VLAN分段可以防止广播风暴波及整个网络。VLAN可以提供建立防火墙的机制,防止交换网络的过量广播。使用VLAN,可以将某个交换端口或用户赋予某一个特定的VLAN组,该VLAN组可以在一个交换网中或跨接多个交换机,在一个VLAN中的广播不会送到VLAN之外。同样,相邻的端口不会收到其他VLAN产生的广播。这样可以减少广播流量,释放带宽给用户应用,减少广播的产生。

②  安全:增强局域网的安全性,含有敏感数据的用户组可与网络的其余部分隔离,从而降低泄露机密信息的可能性。不同VLAN内的报文在传输时是相互隔离的,即一个VLAN内的用户不能和其他VLAN内的用户直接通信,如果不同VLAN要进行通信,则需要通过路由器或三层交换机等三层设备。

③  成本降低:成本高昂的网络升级需求减少,现有带宽和上行链路的利用率更高,因而可节约成本。

④  性能提高:将第二层平面网络划分为多个逻辑工作组(广播域)可以减少网络上不必要的流量并提高性能。

⑤  提高人员工作效率:VLAN为网络管理带来了方便,因为有相似网络需求的用户将共享同一个VLAN。

⑥  简化项目管理或应用管理:VLAN将用户和网络设备聚合到一起,以支持商业需求或地域上的需求。通过职能划分,项目管理或特殊应用的处理都变得十分方便,例如可以轻松管理教师的电子教学开发平台。此外,也很容易确定升级网络服务的影响范围。

⑦  增加了网络连接的灵活性:借助VLAN技术,能将不同地点、不同网络、不同用户组合在一起,形成一个虚拟的网络环境,就像使用本地VLAN一样方便、灵活、有效。VLAN可以降低移动或变更工作站地理位置的管理费用,特别是一些业务情况有经常性变动的公司使用了VLAN后,这部分管理费用大大降低。

分类:

①  根据端口来划分VLAN:许多VLAN厂商都利用交换机的端口来划分VLAN成员。被设定的端口都在同一个广播域中。例如,一个交换机的1,2,3,4,5端口被定义为虚拟网AAA,同一交换机的6,7,8端口组成虚拟网BBB。这样做允许各端口之间的通讯,并允许共享型网络的升级。但是,这种划分模式将虚拟网限制在了一台交换机上。

第二代端口VLAN技术允许跨越多个交换机的多个不同端口划分VLAN,不同交换机上的若干个端口可以组成同一个虚拟网。

以交换机端口来划分网络成员,其配置过程简单明了。因此,从目前来看,这种根据端口来划分VLAN的方式仍然是最常用的一种方式。

②  根据MAC地址划分VLAN:这种划分VLAN的方法是根据每个主机的MAC地址来划分,即对每个MAC地址的主机都配置它属于哪个组。这种划分VLAN方法的最大优点就是当用户物理位置移动时,即从一个交换机换到其他的交换机时,VLAN不用重新配置,所以,可以认为这种根据MAC地址的划分方法是基于用户的VLAN,这种方法的缺点是初始化时,所有的用户都必须进行配置,如果有几百个甚至上千个用户的话,配置是非常累的。而且这种划分的方法也导致了交换机执行效率的降低,因为在每一个交换机的端口都可能存在很多个VLAN组的成员,这样就无法限制广播包了。另外,对于使用笔记本电脑的用户来说,他们的网卡可能经常更换,这样,VLAN就必须不停地配置。

③  根据网络层划分VLAN:这种划分VLAN的方法是根据每个主机的网络层地址或协议类型(如果支持多协议)划分的,虽然这种划分方法是根据网络地址,比如IP地址,但它不是路由,与网络层的路由毫无关系。

这种方法的优点是用户的物理位置改变了,不需要重新配置所属的VLAN,而且可以根据协议类型来划分VLAN,这对网络管理者来说很重要,还有,这种方法不需要附加的帧标签来识别VLAN,这样可以减少网络的通信量。这种方法的缺点是效率低,因为检查每一个数据包的网络层地址是需要消耗处理时间的(相对于前面两种方法),一般的交换机芯片都可以自动检查网络上数据包的以太网帧头,但要让芯片能检查IP帧头,需要更高的技术,同时也更费时。当然,这与各个厂商的实现方法有关。

④  根据IP组播划分VLAN:IP 组播实际上也是一种VLAN的定义,即认为一个组播组就是一个VLAN,这种划分的方法将VLAN扩大到了广域网,因此这种方法具有更大的灵活性,而且也很容易通过路由器进行扩展,当然这种方法不适合局域网,主要是效率不高。

⑤  基于规则的VLAN:也称为基于策略的VLAN。这是最灵活的VLAN划分方法,具有自动配置的能力,能够把相关的用户连成一体,在逻辑划分上称为“关系网络”。网络管理员只需在网管软件中确定划分VLAN的规则(或属性),那么当一个站点加入网络中时,将会被“感知”,并被自动地包含进正确的VLAN中。同时,对站点的移动和改变也可自动识别和跟踪。

采用这种方法,整个网络可以非常方便地通过路由器扩展网络规模。有的产品还支持一个端口上的主机分别属于不同的VLAN,这在交换机与共享式Hub共存的环境中显得尤为重要。自动配置VLAN时,交换机中软件自动检查进入交换机端口的广播信息的IP源地址,然后软件自动将这个端口分配给一个由IP子网映射成的VLAN。

⑥  按用户划分VLAN:基于用户定义、非用户授权来划分VLAN,是指为了适应特别的VLAN网络,根据具体的网络用户的特别要求来定义和设计VLAN,而且可以让非VLAN群体用户访问VLAN,但是需要提供用户密码,在得到VLAN管理的认证后才可以加入一个VLAN。

3.如何实现VLAN间的通信。

答:

① 通过路由器的不同物理接口与交换机上的每个VLAN分别连接。这种方式的优点是管理简单,缺点是网络扩展难度大。每增加一个新的VLAN,都需要消耗路由器的端口和交换机上的访问链接,而且还需要重新布设一条网线。而路由器,通常不会带有太多LAN接口的。

② 通过路由器的逻辑子接口与交换机的各个VLAN连接。这种连接方式要求路由器和交换机的端口都支持汇聚链接,且双方用于汇聚链路的协议自然也必须相同;

③ 用三层以上交换机代替路由器实现VLAN间的通信。目前市场上有许多三层以上的交换机,在这些交换机中,厂家通过硬件或软件的方式将路由功能集成到交换机中,交换机主要用于园区网中,园区网中的路由比较简单,但要求数据交换的速度较快,因此得到了广泛的应用。

 

 

 

 

 

 

1.理解交换机的配置模式。

1)用户模式;2)特权模式;3)全局配置模式;4)子模式。

5)SETUP模式(对话模式)--交互式;6)boot模式(灾难恢复模式)--特定环境

具体内容:

①    用户模式:开机直接进入普通用户模式,在该模式下我们只能查询交换机的一些基础信息,如版本号(show version) 等,权限最低,只能使用少量的查看行政的命令。如需进入特权模式一般需要密码。

②    特权模式:在普通用户模式下输入enable命令即可进入特权用户模式,在该模式下我们可以查看交换机的配置信息和调试信息等等,使用更多的查看性质的命令和做一些少量修改的路由器参数命令,进入全局配置模式不需要任何密码。

③    全局配置模式:在特权用户模式下输入config terminal命令即可进入全局配置模式,在该模式下主要完成全局参数的配置,不能使用查看性质的命令,在此模式下做大量的路由配置模式,可用在此基础上接口配置模式,线路配置模式,路由进程模式。

④    子模式: 1.线路配置模式[主机名(config-line)#]:配置交换机的线路参数

2.接口配置模式[主机名(config-if)#]:配置交换机的接口参数

⑤    SETUP模式(对话模式)--交互式:交换机的初始化配置方式分为两种,一种是steup的交互式配置模式,一种是逐条命令的配置模式。

⑥    boot模式(灾难恢复模式)--特定环境:为了不让实验受交换机以前的配置影响,常常需要先恢复交换机的缺省配置。在特权用户模式下顺序使用erase, restet命令即可恢复交换机的缺省配置。有些地方也称为root模式。

 

2.画出实验所需的网络拓扑图。

――截图(网络拓扑图1个)

 

以上为老师的例图,以下为我的实验截图。(在上次实验的基础上继续完成)

使用软件Cisco Packet Tracer。

设备:选择交换机2950-24命名为SWITCH2,终端设备PC-PT。

连线:PC-9使用配置线连交换机SWITCH2的CONSOLE,

PC-5使用直通线连FastEthernet0/5,PC-6使用直通线连FastEthernet0/6,PC-7使用直通线连FastEthernet0/7,PC-8使用直通线连FastEthernet0/8。

SWITCH和SWITCH2之间使用交叉线连SWITCH的FastEthernet0/10和SWITCH2的FastEthernet0/10

2.为设备设置IP地址,并测试网络连通性。(参见上次实验)

――截图(测试2个图、VLAN信息1个图)

交换机是二层设备,给交换机的VLAN 1配置IP地址。在没有设置VLAN前,所有的端口都默认属于VLAN 1,所以VLAN 1也叫做管理VLAN,显然VLAN1的IP地址就是交换机的IP地址。

给交换机的VLAN 1配置IP地址:

点击PC-9,选择桌面里的终端

设置交换机IP代码:

enable

config terminal

interface VLAN 1

ip address 192.168.1.2 255.255.255.0

no shutdown

end

 

对其他PC机IP配置操作,设置PC-1为192.168.1.10。

点击PC-5中的IP地址配置,进行如下操作,填写好直接关闭即可。

 

对其他PC机IP配置操作,设置:

PC-6为192.168.1.60;PC-7为192.168.1.70;PC-8为192.168.1.80。

 

经测试PC-1、PC-2、PC-3、PC-4是相互连通的,PC-5、PC-6、PC-7、PC-8是相互连通的。下面给出两个连通测试

测试1——PC-5电脑主机ping PC-6、PC-7、PC-8、PC-9电脑主机,网络连通。

点击PC-5,选择桌面里的命令提示符。

代码:ping 192.168.1.60

 

代码:ping 192.168.1.70

 

代码:ping 192.168.1.80

 

代码:ping 192.168.1.2

 

注意:这边可以观察到第一次ping的时候有数据丢失,第二次没有丢失。

 

测试2——PC-5电脑主机ping PC-0、PC-1、PC-2、PC-3、PC-4电脑主机,PC-0网络,PC-1、PC-2、PC-3、PC-4连通。

点击PC-5,选择桌面里的命令提示符。

代码:ping 192.168.1.1

 

代码:ping 192.168.1.10

 

代码:ping 192.168.1.20

 

代码:ping 192.168.1.30 

 

代码:ping 192.168.1.40

 

VLAN信息:

点击PC-0,选择桌面里的终端。

代码:show vlan

 

点击PC-9,选择桌面里的终端。

代码:show vlan

 

3.进行交换机的基础配置。(由于实验课程安排暂时不做)

――截图(每项1个图)

设置明文密码,设置密文密码,设置远程登录密码。

 

4.进行单交换机的VLAN划分,并测试网络连通性。(参见上次实验)

――截图(测试2个图、VLAN信息1个图)

1)创建两个不同的VLAN 10和VLAN 20。

点击PC-9,选择桌面里的终端。

代码:

enable

vlan database

vlan 10 name CHEN1

vlan 20 name CHEN2

exit

 

2)将不同的接口连入刚刚创建的两个VLAN。

点击PC-9,选择桌面里的终端。

代码:

config terminal

interface FastEthernet 0/5

switchport mode access

switchport access vlan 10

exit

interface FastEthernet 0/6

switchport mode access

switchport access vlan 10

exit

interface FastEthernet 0/7

switchport mode access

switchport access vlan 20

exit

interface FastEthernet 0/8

switchport mode access

switchport access vlan 20

exit

show vlan

3)测试。测试结论:相同VLAN,主机彼此可以互相ping通;不同VLAN,主机彼此不能互相ping通。

此时的VLAN划分情况为:VLAN10—PC-5,PC-6;VLAN20—PC-7,PC-8。

相同VLAN测试——PC-5电脑主机ping PC-6电脑主机,网络连通。

点击PC-5,选择桌面里的命令提示符。

代码:ping 192.168.1.60

 

不同VLAN测试——PC-6电脑主机ping PC-7电脑主机,网络不连通。

点击PC-6,选择桌面里的命令提示符。

代码:ping 192.168.1.70

 

5跨交换机的VLAN划分,并测试网络连通性。。

1)先分别在不同的交换机上设置两个不同的VLAN 10和20。

在PC-0和PC-9桌面里的终端执行代码:

enable

vlan database

vlan 10 name CHEN1

vlan 20 name CHEN2

exit

2)将不同的接口连入刚刚创建的两个VLAN。

在PC-0桌面里的终端执行代码:

config terminal

interface FastEthernet 0/1

switchport mode access

switchport access vlan 10

exit

interface FastEthernet 0/2

switchport mode access

switchport access vlan 10

exit

interface FastEthernet 0/3

switchport mode access

switchport access vlan 20

exit

interface FastEthernet 0/4

switchport mode access

switchport access vlan 20

exit

 

在PC-9桌面里的终端执行代码:

config terminal

interface FastEthernet 0/5

switchport mode access

switchport access vlan 10

exit

interface FastEthernet 0/6

switchport mode access

switchport access vlan 10

exit

interface FastEthernet 0/7

switchport mode access

switchport access vlan 20

exit

interface FastEthernet 0/8

switchport mode access

switchport access vlan 20

exit

 

3)在两个交换机间,设置TRUNK。

分别在两个交换机的两个终端上执行代码:

config terminal

interface fastEthernet 0/10

switchport mode trunk

 

  

4)测试。测试结论:相同VLAN,主机彼此可以互相ping通;不同VLAN,主机彼此不能互相ping通。

此时的VLAN划分情况为:

VLAN10—PC-1、PC-2、PC-5、PC-6;VLAN 20—PC-3、PC-4、PC-7、PC-8

相同VLAN测试——PC-6电脑主机ping PC-1电脑主机,网络连通。

点击PC-6,选择桌面里的命令提示符。

代码:ping 192.168.1.10

 

不同VLAN测试——PC-8电脑主机ping PC-2电脑主机,网络不连通。

点击PC-8,选择桌面里的命令提示符。

代码:ping 192.168.1.20

 

1.你的感受。

答:本次实验的内容是上一次实验内容的延申和拓展,经过了上一次的学习,这一次的实验整体完成的比较轻松。

2.你的收获。

答:

①  对数据链路层的主要功能及服务有了一定的了解;

②  加深了对交换机的概念、特点和功能的认识;

③  掌握了网络拓扑图的设计过程;

④  初步掌握了跨交换机的VLAN配置。

3.你的困难。

答:由于本次实验中很多地方都是重复性的工作,在进行操作的时候如果没有留心,一不小心就会忘记了自己做到哪个部分。

4.你的启示。

答:在进行实验操作的时候,不管是难的实验还是简单的实验,其中都会有一些重复性的工作,在进行这些重复性工作的时候不要掉以轻心,也要认真的去完成,粗心大意可能会造成不好的后果。

同时,今天新接触了一个软件,第一次使用的时候并不清楚要怎么操作,操作也不够熟练。但在一天的训练和操作下来,操作更为清楚、速度也更快了。这告诉我们要多多动手,也不用有太多的畏难心理,要勇敢的去尝试和学习。

           

 

 

posted @ 2022-06-21 15:03  波兰布鲸  阅读(24)  评论(1编辑  收藏  举报