03xxxx323(陈XX:交换机配置(1)--单交换机VLAN)

 

《计算机网络》上机实验报告

                                                                                              

专业和班级

 

成绩

 

姓名

陈XX

学号

03xxxx323

课程名称

计算机网络

实验名称

交换机配置(1)--单交换机VLAN

  1. 理解数据链路层的3个基本问题的内容。
  2. 认识交换机的概念、特点和功能。
  3. 掌握网络拓扑图的设计过程。
  4. 理解交换机的配置模式,进行交换机的基础配置。
  5. 初步掌握单交换机的VLAN配置。

简要解释下面网络术语。

1.简述数据链路层的3个基本问题的内容。

答:

3个基本问题:封装成帧、透明传输、差错控制

封装成帧

①    含义:封装成帧指数据链路层给上层交付的协议数据单元添加帧头和帧尾,使之成为一个帧。帧头和帧尾中包含有重要的控制信息。帧头和帧尾的作用之一是帧定界(并不是每一种数据链路层协议的帧都包含帧定界标志)

②    帧格式:帧的首部和尾部分别为四个字段和两个字段。

③    过程:网络层的IP数据报传送到数据链路层就成为帧的数据部分。在帧的数据部分前面和后面分别添加上首部和尾部,构成了一个完整的帧。这样的帧就是数据链路层的数据传送的单元。接受端在收到物理层上交的比特流后,就能根据首部和尾部的标记,从收到的比特流中识别帧的开始和结束。

透明传输:

①    含义:透明传输是指数据链路层对上层交付的传输数据没有任何限制,就好比数据链路层不存在一样。

②    方法:

面向字节的物理链路:使用字节填充(或称字符填充)的方法实现透明传输。特殊点在于数据链路层对上层交付的协议数据单元有限制,其内容不能包括帧定界符。实际上,各种数据链路层协议一定会想办法来解决这个问题。

面向比特的物理链路:使用比特填充的方法实现透明传输。

③    注意:为了提高帧的传输效率,应当使帧的数据部分的长度尽可能大一点。

差错控制:

①    含义:差错检测,是指在发送的码序列(码字)中加入适当的冗余度以使得接收端能够发现传输中是否发生差错的技术。除了用于通信外,差错检测技术也广泛用于信息存储中。

②    原理:差错检测时通过检错码来实现的,检错码C只是所有可能出现的序列集合X的一部分,在发送端只把数据编码成C中的码字来传输,当接收端收到不属于集合C的序列时,则认为发生了传输误码。

③    检验方法:循环冗余校验(CRC)

2.简述交换机的概念、特点和功能。

答:

概念:

交换机(英文:Switch,意为“开关”)是一种用于电信号转发的网络设备。它可以为接入交换机的任意两个网络节点提供独享的电信号通路。最常见的交换机是以太网交换机。其他常见的还有电话语音交换机、光纤交换机等。

特点:

①  低交换延迟。这是交换机的主要特点。从传输延迟的量级来看,如果交换机为几十微秒,则网桥为几百微秒,路由器为几千微秒。

②  支持不同的传输速率和工作模式。交换机的端口可以支持不同的传输速率,如支持10Mbps、100Mbps等。端口可以支持两种工模式全双工和半双工。

③  高传输宽带。

④  支持虚拟局域网服务。交换局域网是虚拟局域网的基础,当前的交换机基本上都只持虚拟局域网。

⑤  局域网交换机则应用于局域网络,用于连接终端设备,如PC机及网络打印机等

 

功能:(最基础的功能是实现数据的交换)

①  像集线器一样,交换机提供了大量可供线缆连接的端口,这样可以采用星型拓扑布线。

②  像中继器、集线器和网桥那样,当它转发帧时,交换机会重新产生一个不失真的方形电信号。

③  像网桥那样,交换机在每个端口上都使用相同的转发或过滤逻辑。

④  像网桥那样,交换机将局域网分为多个冲突域,每个冲突域都是有独立的宽带,因此大大提高了局域网的带宽。

⑤  除了具有网桥、集线器和中继器的功能以外,交换机还提供了更先进的功能,如虚拟局域网(VLAN)和更高的性能。

3.根据你的理解,VLAN能带来什么好处?

答:

概念:

VLAN(Virtual Local Area Network)即虚拟局域网,是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,相互之间的通信就好像它们在同一个网段中一样,由此得名虚拟局域网,由于交换机端口有两种VLAN属性,其一是VLANID,其二是VLANTAG,分别对应VLAN对数据包设置VLAN标签和允许通过的VLANTAG(标签)数据包,不同VLANID端口,可以通过相互允许VLANTAG,构建VLAN。

作用:

①  广播风暴防范:限制网络上的广播,将网络划分为多个VLAN可减少参与广播风暴的设备数量。VLAN分段可以防止广播风暴波及整个网络。VLAN可以提供建立防火墙的机制,防止交换网络的过量广播。使用VLAN,可以将某个交换端口或用户赋予某一个特定的VLAN组,该VLAN组可以在一个交换网中或跨接多个交换机,在一个VLAN中的广播不会送到VLAN之外。同样,相邻的端口不会收到其他VLAN产生的广播。这样可以减少广播流量,释放带宽给用户应用,减少广播的产生。

②  安全:增强局域网的安全性,含有敏感数据的用户组可与网络的其余部分隔离,从而降低泄露机密信息的可能性。不同VLAN内的报文在传输时是相互隔离的,即一个VLAN内的用户不能和其他VLAN内的用户直接通信,如果不同VLAN要进行通信,则需要通过路由器或三层交换机等三层设备。

③  成本降低:成本高昂的网络升级需求减少,现有带宽和上行链路的利用率更高,因而可节约成本。

④  性能提高:将第二层平面网络划分为多个逻辑工作组(广播域)可以减少网络上不必要的流量并提高性能。

⑤  提高人员工作效率:VLAN为网络管理带来了方便,因为有相似网络需求的用户将共享同一个VLAN。

⑥  简化项目管理或应用管理:VLAN将用户和网络设备聚合到一起,以支持商业需求或地域上的需求。通过职能划分,项目管理或特殊应用的处理都变得十分方便,例如可以轻松管理教师的电子教学开发平台。此外,也很容易确定升级网络服务的影响范围。

⑦  增加了网络连接的灵活性:借助VLAN技术,能将不同地点、不同网络、不同用户组合在一起,形成一个虚拟的网络环境,就像使用本地VLAN一样方便、灵活、有效。VLAN可以降低移动或变更工作站地理位置的管理费用,特别是一些业务情况有经常性变动的公司使用了VLAN后,这部分管理费用大大降低。

 

 

 

 

 

 

1.理解交换机的配置模式。

1)用户模式;2)特权模式;3)全局配置模式;4)子模式。

5)SETUP模式(对话模式)--交互式;6)boot模式(灾难恢复模式)--特定环境

具体内容:

①    用户模式:开机直接进入普通用户模式,在该模式下我们只能查询交换机的一些基础信息,如版本号(show version) 等,权限最低,只能使用少量的查看行政的命令。如需进入特权模式一般需要密码。

②    特权模式:在普通用户模式下输入enable命令即可进入特权用户模式,在该模式下我们可以查看交换机的配置信息和调试信息等等,使用更多的查看性质的命令和做一些少量修改的路由器参数命令,进入全局配置模式不需要任何密码。

③    全局配置模式:在特权用户模式下输入config terminal命令即可进入全局配置模式,在该模式下主要完成全局参数的配置,不能使用查看性质的命令,在此模式下做大量的路由配置模式,可用在此基础上接口配置模式,线路配置模式,路由进程模式。

④    子模式: 1.线路配置模式[主机名(config-line)#]:配置交换机的线路参数

2.接口配置模式[主机名(config-if)#]:配置交换机的接口参数

⑤    SETUP模式(对话模式)--交互式:交换机的初始化配置方式分为两种,一种是steup的交互式配置模式,一种是逐条命令的配置模式。

⑥    boot模式(灾难恢复模式)--特定环境:为了不让实验受交换机以前的配置影响,常常需要先恢复交换机的缺省配置。在特权用户模式下顺序使用erase, restet命令即可恢复交换机的缺省配置。有些地方也称为root模式。

2.画出实验所需的网络拓扑图。

――截图(网络拓扑图1个)

 

以上为老师的例图,以下为我的实验截图。

使用软件Cisco Packet Tracer。

设备:选择交换机2950-24,终端设备PC-PT。

连线:PC-0使用配置线连交换机的CONSOLE,

PC-1使用直通线连FastEthernet0/1,PC-2使用直通线连FastEthernet0/2,PC-3使用直通线连FastEthernet0/3,PC-4使用直通线连FastEthernet0/4。

3.为设备设置IP地址,并测试网络连通性。

――截图(测试2个图、VLAN信息1个图)

交换机是二层设备,给交换机的VLAN 1配置IP地址。在没有设置VLAN前,所有的端口都默认属于VLAN 1,所以VLAN 1也叫做管理VLAN,显然VLAN1的IP地址就是交换机的IP地址。

给交换机的VLAN 1配置IP地址:

点击PC-0,选择桌面里的终端。

  

设置交换机IP代码:

enable

config terminal

interface VLAN 1

ip address 192.168.1.1 255.255.255.0

no shutdown

end

 

对其他PC机IP配置操作,设置PC-1为192.168.1.10。

点击PC-1中的IP地址配置,进行如下操作,填写好直接关闭即可。

 

对其他PC机IP配置操作,设置:

PC-2为192.168.1.20;PC-3为192.168.1.30;PC-4为192.168.1.40。

 

经测试PC-1、PC-2、PC-3、PC-4是相互连通的,下面给出两个连通测试

测试1——PC-1电脑主机ping PC-2电脑主机,网络连通。

点击PC-1,选择桌面里的命令提示符。

代码:ping 192.168.1.20

 

测试2——PC-3电脑主机ping PC-1电脑主机,网络连通。

点击PC-3,选择桌面里的命令提示符。

代码:ping 192.168.1.10

 

VLAN信息:

点击PC-0,选择桌面里的终端。

代码:show vlan

 

4.进行交换机的基础配置。(由于实验课程安排暂时不做)

――截图(每项1个图)

设置明文密码,设置密文密码,设置远程登录密码。

 

5.进行单交换机的VLAN划分,并测试网络连通性。

――截图(测试2个图、VLAN信息1个图)

1)创建两个不同的VLAN 10和VLAN 20。

点击PC-0,选择桌面里的终端。

代码:

enable

vlan database

vlan 10 name CHEN1

vlan 20 name CHEN2

exit

 

2)将不同的接口连入刚刚创建的两个VLAN。

点击PC-0,选择桌面里的终端。

代码:

config terminal

interface FastEthernet 0/1

switchport mode access

switchport access vlan 10

exit

interface FastEthernet 0/2

switchport mode access

switchport access vlan 10

exit

interface FastEthernet 0/3

switchport mode access

switchport access vlan 20

exit

interface FastEthernet 0/4

switchport mode access

switchport access vlan 20

exit

show vlan

 

3)测试。测试结论:相同VLAN,主机彼此可以互相ping通;不同VLAN,主机彼此不能互相ping通。

此时的VLAN划分情况为:VLAN10—PC-1,PC-2;VLAN20—PC-3,PC-4。

相同VLAN测试——PC-1电脑主机ping PC-2电脑主机,网络连通。

点击PC-1,选择桌面里的命令提示符。

代码:ping 192.168.1.20

 

不同VLAN测试——PC-3电脑主机ping PC-1电脑主机,网络不连通。

点击PC-3,选择桌面里的命令提示符。

代码:ping 192.168.1.10

 

 

 

1.你的感受。

答:

本次实验主要通过思科Cisco Packet Tracer仿真实验软件进行操作,对于计算机网络的学习,如果只是停留在概念文字上并不一定能对整个动态过程做到很好的把握。仿真软件中开始线路的连接点是红色的,说明没有连接上;后面变成了绿色的,说明连接上了;这种直观的感觉可以让我们体验到真实实验中的线路情况变化。

2.你的收获。

答:

①    理解数据链路层的3个基本问题的内容;

②    认识交换机的概念、特点和功能;

③    掌握网络拓扑图的设计过程;

④    理解交换机的配置模式,进行交换机的基础配置;

⑤    初步掌握单交换机的VLAN配置。

3.你的困难。

答:

在进行什么什么的时候,忘记添加enable,会出现“Invalid input detected at ‘^’ marker.”,解决方法是加上enable即可。

 

4.你的启示。

答:

可以多多借助仿真实验软件进行实践操作,加深对理论知识的理解和掌握。

 

           
posted @ 2022-06-21 14:55  波兰布鲸  阅读(39)  评论(1编辑  收藏  举报