PTA 乙级 1067试密码 Java代码

PAT 乙级 1067 试密码

当你试图登录某个系统却忘了密码时,系统一般只会允许你尝试有限多次,当超出允许次数时,账号就会被锁死。本题就请你实现这个小功能。

题目要求

输入格式:

输入在第一行给出一个密码(长度不超过 20 的、不包含空格、Tab、回车的非空字符串)和一个正整数 N(≤ 10),分别是正确的密码和系统允许尝试的次数。随后每行给出一个以回车结束的非空字符串,是用户尝试输入的密码。输入保证至少有一次尝试。当读到一行只有单个 # 字符时,输入结束,并且这一行不是用户的输入。

输出格式:

对用户的每个输入,如果是正确的密码且尝试次数不超过 N,则在一行中输出 Welcome in,并结束程序;如果是错误的,则在一行中按格式输出 Wrong password: 用户输入的错误密码;当错误尝试达到 N 次时,再输出一行 Account locked,并结束程序。

输入样例 1:

Correct%pw 3
correct%pw
Correct@PW
whatisthepassword!
Correct%pw
#

输出样例 1:

Wrong password: correct%pw
Wrong password: Correct@PW
Wrong password: whatisthepassword!
Account locked

输入样例 2:

cool@gplt 3
coolman@gplt
coollady@gplt
cool@gplt
try again
#

输出样例 2:

Wrong password: coolman@gplt
Wrong password: coollady@gplt
Welcome in

解题代码

Java代码
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
 
 
public class Main03 {
    public static void main(String[] args) throws IOException {
        BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));
        String[] input = bf.readLine().split(" ");
        String pwd = input[0];
        int n = Integer.parseInt(input[1]);
        int count = 0;
        String str;
        do {
            str = bf.readLine();
            if (count == n) {
                System.out.println("Account locked");
                break;
            } else {
                if ("#".equals(str)) {
                    break;
                }
                if (!pwd.equals(str)) {
                    System.out.println("Wrong password: " + str);
                } else {
                    System.out.println("Welcome in");
                    break;
                }
                count++;
            }
        } while (!"#".equals(str));
    }
}
 
整理之后的代码:
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.StreamTokenizer;
 
public class Main {
    public static void main(String[] args) throws IOException {
        BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));
        String[] input = bf.readLine().split(" ");
        String pwd = input[0];
        int n = Integer.parseInt(input[1]);
        int count = 0;
        String str;
        while (true) {
            str = bf.readLine();
            if (count == n) {
                System.out.println("Account locked");
                break;
            }
            if ("#".equals(str)) {
                break;
            }
            if (pwd.equals(str)) {
                System.out.println("Welcome in");
                break;
            } else {
                System.out.println("Wrong password: " + str);
            }
            count++;
        }
    }
}
 

解题思路:

在解题过程中需要考虑两种特殊情况
第一种是直接#结束,不输入密码的情况,输出就结束程序;
第二种是输入次数用完之后,使用#输入,会输出"Account locked",而不是结束程序。
 
第一种输入:
123456 3
#
第一种输出:
 
第二种输入:
123456 3
111111
222222
333333
#
第二种输出:
Wrong password: 111111
Wrong password: 222222
Wrong password: 333333
Account locked
 
一开始出错的原因是测试用例2和测试用例4不能通过
测试用例4应该是第二种情况
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
 
 
public class Main03 {
    public static void main(String[] args) throws IOException {
        BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));
        String[] input = bf.readLine().split(" ");
        String pwd = input[0];
        int n = Integer.parseInt(input[1]);
        int count = 0;
        String str;
        do {
            str = bf.readLine();
            if ("#".equals(str)) {
                break;
            }
            if (count == n) {
                System.out.println("Account locked");
                break;
            } else {
                
                if (!pwd.equals(str)) {
                    System.out.println("Wrong password: " + str);
                } else {
                    System.out.println("Welcome in");
                    break;
                }
                count++;
            }
        } while (!"#".equals(str));
    }
}

 

这个程序会出现测试用例4不能通过
在IDEAJ中的运行情况:
 
 
 
以下代码会出现测试用例2不能通过的情况,就是如果在没有超过错误次数时,使用#结束输入的情况,同时也给出了在IDEAJ中的运行情况
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
 
 
public class Main03 {
    public static void main(String[] args) throws IOException {
        BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));
        String[] input = bf.readLine().split(" ");
        String pwd = input[0];
        int n = Integer.parseInt(input[1]);
        int count = 0;
        String str;
        do {
            str = bf.readLine();
            /*if ("#".equals(str)) {
                break;
            }*/
            if (count == n) {
                System.out.println("Account locked");
                break;
            } else {
 
 
                if (!pwd.equals(str)) {
                    System.out.println("Wrong password: " + str);
                } else {
                    System.out.println("Welcome in");
                    break;
                }
                count++;
            }
        } while (!"#".equals(str));
    }
}

 

在IDEAJ中的运行情况:
 
 
posted @ 2022-05-02 22:15  Pudding10335  阅读(39)  评论(0编辑  收藏  举报