实现QQ新帐户申请和老帐户登陆的简化版功能。最大挑战是:据说现在的QQ号码已经有10位数了。

输入格式:

输入首先给出一个正整数N(≤),随后给出N行指令。每行指令的格式为:“命令符(空格)QQ号码(空格)密码”。其中命令符为“N”(代表New)时表示要新申请一个QQ号,后面是新帐户的号码和密码;命令符为“L”(代表Login)时表示是老帐户登陆,后面是登陆信息。QQ号码为一个不超过10位、但大于1000(据说QQ老总的号码是1001)的整数。密码为不小于6位、不超过16位、且不包含空格的字符串。

输出格式:

针对每条指令,给出相应的信息:

1)若新申请帐户成功,则输出“New: OK”;
2)若新申请的号码已经存在,则输出“ERROR: Exist”;
3)若老帐户登陆成功,则输出“Login: OK”;
4)若老帐户QQ号码不存在,则输出“ERROR: Not Exist”;
5)若老帐户密码错误,则输出“ERROR: Wrong PW”。

输入样例:

5
L 1234567890 myQQ@qq.com
N 1234567890 myQQ@qq.com
N 1234567890 myQQ@qq.com
L 1234567890 myQQ@qq
L 1234567890 myQQ@qq.com

输出样例:

ERROR: Not Exist
New: OK
ERROR: Exist
ERROR: Wrong PW
Login: OK


代码:
#include <iostream>
#include <algorithm>
#include <map>
#include <cstring>
#include <cstdio>
using namespace std;
char ope[2],num[11],psw[17];
int n;
int main()
{
    map<string,string> p;
    map<string,int> q;
    scanf("%d",&n);
    for(int i = 0;i < n;i ++)
    {
        scanf("%s %s %s",ope,num,psw);
        if(!strcmp(ope,"L"))
        {
            if(q[num])
            {
                if(p[num] == psw)printf("Login: OK\n");
                else printf("ERROR: Wrong PW\n");
            }
            else printf("ERROR: Not Exist\n");
        }
        else
        {
            if(q[num])printf("ERROR: Exist\n");
            else
            {
                printf("New: OK\n");
                q[num] = 1;
                p[num] = psw;
            }
        }
    }
}

 2019重做:

#include <iostream>
#include <cstdlib>
#include <map>
using namespace std;
int n;
map<string,string> mp;
int main() {
    string a,b,c;
    cin>>n;
    while(n --) {
        cin>>a>>b>>c;
        if(a == "N") {
            if(mp.find(b) == mp.end()) {
                mp[b] = c;
                cout<<"New: OK"<<endl;
            }
            else cout<<"ERROR: Exist"<<endl;
        }
        else {
            if(mp.find(b) == mp.end()) {
                cout<<"ERROR: Not Exist"<<endl;
            }
            else if(mp[b] != c) {
                cout<<"ERROR: Wrong PW"<<endl;
            }
            else {
                cout<<"Login: OK"<<endl;
            }
        }
    }
}