POJ 2387 Til the Cows Come Home 最短路

                                                                           Til the Cows Come Home

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.
Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.
Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N
* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS:
There are five landmarks.
OUTPUT DETAILS:
Bessie can get home by following trails 4, 3, 2, and 1.
代码
#include<cstdio> 
#include<iostream>
#include<queue>
#include<cstring>
#define M 1010
int cap[M][M] , d[M] ;
#define INF 2000000
int min( int a , int b ){
	if( a > b ) return b ;
	else return a ;
}
using namespace std ;
queue< int > q ;
bool vi[M] ;
int main()
{   
	
   int i , j , n , m , v , u , w;
   while( scanf( "%d%d" , &m , &n ) != EOF ){
	   memset( vi , 0 , sizeof(vi) ) ;
	   for( i = 1 ; i <= n ; i++)
		   for( j = 1 ; j <= n ; j++){
			   if( i == j )cap[i][j] = 0 ;
			   else cap[i][j] = INF ;
		   }
	   for( i = 1 ; i <= m ; i++)
	   {
		   scanf( "%d%d%d" , &u , &v , &w ) ;
		   cap[u][v] = min( w , cap[u][v]) ; //有重边 = = 
		   cap[v][u] = min( w , cap[v][u]);

	   }
	   q.push( n ) ;
	   for( i = 1 ,d[n] = 0 ; i < n ;i++) 
		   d[i] = INF ;
	   while( ! q.empty()){

		   int f = q.front() ; q.pop() ;
		   vi[f] = 0 ;
		   for( i = 1 ;i <= n ;i++)
			   if( d[i] > cap[f][i] + d[f] )
		   { 
                 d[i] = cap[f][i] + d[f] ;
				 if( vi[i] == 0){
					 vi[i] = 1 ;
					 q.push( i ) ;
				 }
		   }
	   }
	   cout << d[1] << endl; 
   }
}

  

posted @ 2013-04-01 22:10  _log__  阅读(198)  评论(0编辑  收藏  举报