hdu 4185 二分图最大匹配

Oil Skimming

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1487    Accepted Submission(s): 612


Problem Description
Thanks to a certain "green" resources company, there is a new profitable industry of oil skimming. There are large slicks of crude oil floating in the Gulf of Mexico just waiting to be scooped up by enterprising oil barons. One such oil baron has a special plane that can skim the surface of the water collecting oil on the water's surface. However, each scoop covers a 10m by 20m rectangle (going either east/west or north/south). It also requires that the rectangle be completely covered in oil, otherwise the product is contaminated by pure ocean water and thus unprofitable! Given a map of an oil slick, the oil baron would like you to compute the maximum number of scoops that may be extracted. The map is an NxN grid where each cell represents a 10m square of water, and each cell is marked as either being covered in oil or pure water.
 

 

Input
The input starts with an integer K (1 <= K <= 100) indicating the number of cases. Each case starts with an integer N (1 <= N <= 600) indicating the size of the square grid. Each of the following N lines contains N characters that represent the cells of a row in the grid. A character of '#' represents an oily cell, and a character of '.' represents a pure water cell.
 

 

Output
For each case, one line should be produced, formatted exactly as follows: "Case X: M" where X is the case number (starting from 1) and M is the maximum number of scoops of oil that may be extracted.
 

 

Sample Input
1 6 ...... .##... .##... ....#. ....## ......
 

 

Sample Output
Case 1: 3
 

 

Source
 
 
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 605;
const int INF = 1000000000;
bool vis[maxn];
int link[maxn];
int G[maxn][maxn];
int x_cnt;
int y_cnt;
int temp[maxn][maxn];
char str[maxn][maxn];
bool find(int u)
{
    for(int i = 1; i <= y_cnt; i++)
    {
        if(!vis[i] && G[u][i])
        {
            vis[i] = true;
            if(link[i] == -1 || find(link[i]))
            {

                link[i] = u;
                return true;
            }
        }
    }
    return false;
}
int solve()
{
    int num = 0;
    memset(link, -1, sizeof(link));
    for(int i = 1; i <= x_cnt; i++)
    {
        memset(vis, false, sizeof(vis));
        if(find(i))
            num++;
    }
    return num;
}
int main()
{
    int t,cnt=0;
    scanf("%d",&t);
    while(t--){
            cnt++;
            int n;
            scanf("%d",&n);
          int   tmp=0;
            memset(temp,0,sizeof(temp));
            memset(G,0,sizeof(G));
            memset(str,0,sizeof(str));
        for(int i=0;i<n;i++)
        {
          scanf("%s",&str[i]);
          for(int j=0;j<n;j++)
           if(str[i][j]=='#')
            temp[i][j]=++tmp;
        }
         x_cnt=tmp, y_cnt=tmp;
         for(int i=0;i<n;i++)
          for(int j=0;j<n;j++)
          {
              if(str[i][j]!='#') continue;
              if(i>0&&str[i-1][j]=='#') G[temp[i][j]][temp[i-1][j]]=1;
              if(i<n-1&&str[i+1][j]=='#') G[temp[i][j]][temp[i+1][j]]=1;
              if(j>0&&str[i][j-1]=='#') G[temp[i][j]][temp[i][j-1]]=1;
              if(j<n-1&&str[i][j+1]=='#') G[temp[i][j]][temp[i][j+1]]=1;
          }



       printf("Case %d: %d\n",cnt,solve()/2);
    }
    return 0;
}

 

posted @ 2015-08-14 08:55  柳下_MBX  阅读(366)  评论(0编辑  收藏  举报