栈-Uva 514


      
               

  Rails

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only
 a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.
 
The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has  coaches
 numbered in increasing order . The chief for train reorganizations must know whether it is possible to marshal coaches continuing
 in the direction B so that their order will be . Help him and write a program that decides whether it is possible to
 get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there
 can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.
Input
The input file consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described
 above. In each of the next lines of the block there is a permutation of  The
 last line of the block contains just 0.
The last block consists of just one line containing 0.
Output
The output file contains the lines corresponding to the lines with permutations in the input file. A line of the output file contains Yes if it
 is possible to marshal the coaches in the order required on the corresponding line of the input file. Otherwise it contains No. In addition, there is one empty line after the lines corresponding
 to one block of the input file. There is no line in the output file corresponding to the last ``null'' block of the input file.
Sample Input
5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output
Yes
No
Y
---------------------
注意123进栈然后出栈 45再进栈后出栈的情况
#include<cstdio>
#include<stack>
using namespace std;
const int MAXN =1000+10;

int n,target[MAXN];

int main()
{
    while(scanf("%d",&n)==1)
    {
        stack<int>s;
        int A=1,B=1;
        for(int i=1;i<=n;i++) scanf("%d",&target[i]);
        int ok=1;
        while(B<=n)
        {
            if(A==target[B]) {A++;B++;}
            else if(!s.empty()&&s.top()==target[B])  {s.top();B++;}
            else if(A<=n) s.push(A++);
            else {
                ok=0;break;
            }    
        }
        printf("%s\n",ok?"Yes":"No");
    }
    return 0;
}
 

stack是一个容器类的改编,提供栈的全部功能

emept() 栈为空则返回为真

pop() 移除栈顶元素

push() 在栈顶增加元素

size() 返回栈中元素数目

top()  返回栈顶元素

posted @ 2018-10-13 23:25  西柠58  阅读(112)  评论(0编辑  收藏  举报