03 333(朱 :交换机配置(2)--跨交换机vlan)

《计算机网络》上机实验报告

                                                                                                

专业和班级

 2019级 ( )班

成绩

 

姓名

学号

03 333

课程名称

计算机网络

实验名称

交换机配置(2)--跨交换机VLAN

  1. 简述数据链路层的主要功能及服务。
  2. 认识交换机的概念、特点和功能。
  3. 掌握网络拓扑图的设计过程。
  4. 初步掌握跨交换机的VLAN配置。

简要解释下面网络术语。

1.简述数据链路层的主要功能及服务。

答:

主要功能:

①将数据包封装为帧;

②对等层通信,将帧交付给另一个节点的数据链路层;

③差错检测和流量控制;

④MAC寻址;

⑤区分数据和控制信息;

⑥透明传输。

 

服务:数据链路层最基本的服务是将源计算机网络层来的数据可靠的传输到相邻节点的目标计算机的网络层。

 

2.简述VLAN的概念、作用和分类。

答:

概念:VLAN(虚拟局域网)是对连接到的第二层交换机端口的网络用户的逻辑分段,不受网络用户的物理位置限制而根据用户需求进行网络分段。一个VLAN可以在一个交换机或者跨交换机实现。VLAN可以根据网络用户的位置、作用、部门或者根据网络用户所使用的应用程序和协议来进行分组。基于交换机的虚拟局域网能够为局域网解决冲突域、广播域、带宽问题。

作用:

①限制广播域。广播域被限制在一个VLAN内,提高了网络处理能力。

②增强局域网的安全性。VLAN的优势在于VLAN内部的广播和单播流量不会被转发到其他VLAN中,从而有助于控制网络流量、减少设备投资、简化网络管理、提高网络安全性。

③灵活构建虚拟组。用VLAN可以划分不同的用户到不同的工作组,同一工作组的用户也不必局限于某一固定的物理范围,网络构建和维护更加方便灵活。

④性能提高。将第二平面网络划分为多个逻辑工作组(广播域)可以减少网络上不必要的流量并提高性能。

⑤成本降低。成本高昂的网络升级需求减少,现有带宽和上行链路的利用率更高,因而可节约成本。

⑥提高人员工作效率。VLAN为网络管理带来了方便,因为有相似网络需求的用户将共享同一个VLAN。

⑦简化项目管理或应用管理。VLAN将用户和网络设备聚合到一起,以支持商业需求或地域上的需求。通过职能划分,项目管理或特殊应用的处理都变得十分方便,例如可以轻松管理教师的电子教学开发平台。此外,也很容易确定升级网络服务的影响范围。

分类:

①基于端⼝的VLAN:这是划分VLAN最简单也是最有效的⽅法,实际上就是某种交换端⼝的集合。管理员只要管理和配置交换端⼝,⽽不管交换端⼝连接什么设备。

②基于MAC的VLAN:按MAC地址来划分VLAN实际上是将某些⼯作站和服务器划属于某个VLAN,设备根据⾃⼰⽹卡的MAC地址唯⼀确定VLAN,当设备移动时,VLAN能够⾃动识别,⽽⽆需重新配置,⾮常⽅便。

③基于IP的VLAN:根据⽤户三层逻辑地址来进⾏VLAN划分,不同的IP等地址可以划分进不同的VLAN。但注意这个不是路由。只要⽤户的IP地址不变,VLAN号也不变,这与它的地址和逻辑位置⽆关,相对于MAC的VLAN更加⽅便。

④基于策略的VLAN:通常可以根据MAC、IP、以太⽹协议类型、上层应⽤等来进行灵活的划分。

⑤基于网络层协议的VLAN :VLAN按网络层协议来划分,可分为IP、IPX、DECnet、AppleTalk、Banyan等VLAN网络。这种按网络层协议来组成的VLAN,可使广播域跨越多个VLAN交换机。

⑥按用户定义、非用户授权划分的VLAN :基于用户定义、非用户授权来划分VLAN,是指为了适应特别的VLAN网络,根据具体的网络用户的特别要求来定义和设计VLAN,而且可以让非VLAN群体用户访问VLAN,但是需要提供用户密码,在得到VLAN管理的认证后才可以加入一个VLAN。

总的来说就两个分类,基于端口划分的静态VLAN和基于MAC地址动态VLAN。

 

3.如何实现VLAN间的通信。

答:

①通过路由器的不同物理接口与交换机上的每个VLAN分别连接:这种方式的优点是管理简单,缺点是网络扩展难度大。每增加一个新的VLAN,都需要消耗路由器的端口和交换机上的访问链接,而且还需要重新布设一条网线。而路由器,通常不会带有太多LAN接口的。

②通过路由器的逻辑子接口与交换机的各个VLAN连接:这种连接方式要求路由器和交换机的端口都支持汇聚链接,且双方用于汇聚链路的协议自然也必须相同。

③用三层以上交换机代替路由器实现VLAN间的通信:目前市场上有许多三层以上的交换机,在这些交换机中,厂家通过硬件或软件的方式将路由功能集成到交换机中,交换机主要用于园区网中,园区网中的路由比较简单,但要求数据交换的速度较快,因此得到了广泛的应用。

 

 

 

 

 

 

 

1.理解交换机的配置模式

1)用户模式;2)特权模式;3)全局配置模式;4)子模式。

5)SETUP模式(对话模式)--交互式;6)boot模式(灾难恢复模式)--特定环境

 

1)用户模式

当用户通过交换机的控制台端口或Telnet会话连接并登录到交换机时,此时所处的命令执行模式就是用户EXEC模式。在该模式下,只执行有限的一组命令,这些命令通常用于查看显示系统信息、改变终端设置和执行一些最基本的测试命令,如ping、traceroute等。

2)特权模式

在用户EXEC模式下,执行enable命令,将进入到特权EXEC模式。在该模式下我们可以查看交换机的配置信息和调试信息等等,使用更多的查看性质的命令和做一些少量修改的路由器参数命令,进入全局配置模式不需要任何密码。

3)全局配置模式

在特权模式下,执行configure terminal命令,即可进入全局配置模式。在该模式下,只要输入一条有效的配置命令并回车,内存中正在运行的配置就会立即改变生效。该模式下的配置命令的作用域是全局性的,是对整个交换机起作用。

4)子模式

在全局配置模式下,执行interface命令,即进入接口配置模式。在该模式下,可对选定的接口(端口)进行配置,并且只能执行配置交换机端口的命令。

5)SETUP模式(对话模式)—交互式

交换机的初始化配置方式分为两种,一种是steup的交互式配置模式,一种是逐条命令的配置模式。

6)boot模式(灾难恢复模式)--特定环境

为了不让实验受交换机以前的配置影响,常常需要先恢复交换机的缺省配置。在特权用户模式下顺序使用erase, restet命令即可恢复交换机的缺省配置。

 

2.画出实验所需的网络拓扑图。

――截图(网络拓扑图1个)

 

 

网络拓扑图:

 

 

3.为设备设置IP地址,并测试网络连通性。(参见上次实验)

――截图(测试2个图、VLAN信息1个图)

交换机是二层设备,给交换机的VLAN 1配置IP地址。在没有设置VLAN前,所有的端口都默认属于VLAN 1,所以VLAN 1也叫做管理VLAN,显然VLAN1的IP地址就是交换机的IP地址。

 

步骤:

1)设置IP地址

 

①设置交换机IP

点击PC0→桌面→终端

输入:

Switch>enable

Switch#configure terminal  

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#interface vlan 1

Switch(config-if)#ip address 192.168.1.1 255.255.255.0

Switch(config-if)#no shutdown

 

 

②相关IP设置

点击PC1→桌面→IP地址配置→手动设置

IP地址:192.168.1.10

子网掩码:255.255.255.0

默认网关:192.168.1.1

 

 

 

对PC2、PC3、PC4进行类似操作,IP地址分别为

PC2  192.168.1.20

PC3  192.168.1.30

PC4  192.168.1.40

 

2)测试网络连通性

经测试,PC1、PC2、PC3、PC4之间是相互连通的。

 

以下给出其中两个测试的过程即结果:

①PC1 ping PC2

点击PC1→桌面→命令提示符

输入:ping 192.168.1.20

 

②PC2 ping PC3

点击PC2→桌面→命令提示符

输入:ping 192.168.1.30

 

 

 

3VLAN信息

点击PC0→桌面→终端

输入:show vlan

 

 

4.进行交换机的基础配置

――截图(每项1个图)

设置明文密码,设置密文密码,设置远程登录密码。

 

 

5.进行单交换机的VLAN划分,并测试网络连通性。(参见上次实验)

――截图(测试2个图、VLAN信息1个图)

 

1)创建两个不同的VLAN 100和VLAN 200

 

点击PC0→桌面→终端

输入:

Switch#vlan database

Switch(vlan)#vlan 100 name v1

Switch(vlan)#vlan 200 name v2

 

 

 

2)将不同的接口连入刚刚创建的两个VLAN。

 

PC0终端中输入

Switch#configure terminal

Switch(config)#interface fastEthernet 0/1

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 100

Switch(config-if)#exit

Switch(config)#interface fastEthernet  0/2

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 100

Switch(config-if)#exit

Switch(config)#interface fastEthernet 0/3

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 200

Switch(config-if)#exit

Switch(config)#interface fastEthernet 0/4

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 200

 

3)测试。测试结论:相同VLAN,主机彼此可以互相ping通;不同VLAN,主机彼此不能互相ping通。

 

VLAN划分情况:

VLAN 100:PC1、PC2

VLAN 200:PC3、PC4

 

①相同VLAN测试:

 

PC1 ping PC2

在PC1的命令提示符中输入:ping 192.168.1.20

 

PC3 ping PC4

在PC3的命令提示符中输入:ping 192.168.1.20

 

 

②不同VALN测试:

 

PC1 ping PC3:

在PC1的命令提示符中输入:ping 192.168.1.30

PC1 ping PC4:

在PC1的命令提示符中输入:ping 192.168.1.40

 

 

PC2 ping PC3:

在PC2的命令提示符中输入:ping 192.168.1.30

PC2 ping PC4:

在PC2的命令提示符中输入:ping 192.168.1.40

 

 

6.跨交换机的VLAN划分,并测试网络连通性。

 

1)先分别在不同的交换机上设置两个不同的VLAN 100和200

 

分别在PC0PC5终端输入代码:

Switch#vlan database

Switch(vlan)#vlan 100 name v1

Switch(vlan)#vlan 200 name v2

 

2)将不同的接口连入刚刚创建的两个VLAN。

 

PC0终端输入代码:

Switch#configure terminal

Switch(config)#interface fastEthernet 0/1

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 100

Switch(config-if)#exit

Switch(config)#interface fastEthernet  0/2

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 100

Switch(config-if)#exit

Switch(config)#interface fastEthernet 0/3

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 200

Switch(config-if)#exit

Switch(config)#interface fastEthernet 0/4

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 200

 

 

PC5终端输入代码:

Switch#configure terminal

Switch(config)#interface fastEthernet 0/6

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 100

Switch(config-if)#exit

Switch(config)#interface fastEthernet  0/7

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 100

Switch(config-if)#exit

Switch(config)#interface fastEthernet 0/8

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 200

Switch(config-if)#exit

Switch(config)#interface fastEthernet 0/9

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 200

 

3)在两个交换机间,设置TRUNK。

 

PC0PC5终端分别运行代码:

Switch>enable

Switch#configure terminal

Switch(config)#interface fastEthernet 0/10

Switch(config-if)#switchport mode trunk

 

4)测试。测试结论:相同VLAN,主机彼此可以互相ping通;不同VLAN,主机彼此不能互相ping通。

 

VLAN划分情况:

VLAN100PC1PC2PC6PC7

VLAN200PC3PC4PC8PC9

 

测试:

相同VLAN

PC1  ping  PC6PC7

ping 192.168.1.60

ping 192.168.1.70

 

 

不同VLAN

PC2  ping  PC8PC9

ping 192.168.1.80

ping 192.168.1.90

 

 

 

 

 

1.你的感受。

答:

相比于上一个实验,更加熟悉实验的流程和代码,做起来更为顺畅,效率更高。对交换机的功能有了更深刻的了解。

 

2.你的收获。

答:

了解了数据链路层的主要功能及服务;认识了交换机的概念、特点和功能;掌握了网络拓扑图的设计过程;初步掌握了跨交换机的VLAN配置。

 

3.你的困难。

答:

容易失误的点:在主机终端退出特权模式后,忘记重新进入。或是退出config以后忘记重新进入。

 

4.你的启示。

答:学习计算机网络,既要认真学习理论知识,也要动手实践代码。多实践,对理论知识的理解就更为深刻和准确。

 

 

posted @ 2022-06-21 14:48  03*333  阅读(9)  评论(1编辑  收藏  举报