随笔-30  评论-90  文章-0 

[原]Unable to start debugging on the web server.Debugging failes because integrated Windows authentication is not enabled.

        今天调试程序的时候遇到如下问题:“Unable to start debugging on the web server.Debugging failes because integrated Windows authentication is not enabled.”。
        先是用Baidu搜索一下:找到这篇文章——Debugging Failed Because Integrated Windows Authentication Is Not Enabled  。
        其中提到了MSDN提供的解决方法:
        To enable integrated Windows authentication:
        1.Log onto the Web server using an administrator account. 
        2.From the Start menu, open the Administrative Tools Control Panel. 
        3.In the Administrative Tools window, double-click Internet Information Services. 
        4.In the Internet Information Services window, use the tree control to open the node named for the Web server.
A Web Sites folder appears beneath the server name. 
        5.You can configure authentication for all Web sites or for individual Web sites. To configure authentication for all Web sites, right-click the Web Sites folder and choose Properties from the shortcut menu. To configure authentication for an individual Web site, open the Web Sites folder, right-click the individual Web site, and choose Properties from the shortcut menu 
        6.In the Properties dialog box, select the Directory Security tab. 
        7.In the Anonymous access and authentication section, click the Edit button. 
        8.In the Authentication Methods dialog box, under Authenticated access, select Integrated Windows authentication. 
        9.Click OK to close the Authentication Methods dialog box. 
        10.Click OK to close the Properties dialog box. 
        11.Close the Internet Information Services window. 

        在启发之下,我怀疑是和我修改了IIS的访问权限有关:勾选上“集成 Windows 身份验证”,一切OK了!

 

posted on 2006-06-21 12:35 淡泊江湖 阅读(...) 评论(...) 编辑 收藏