生理周期POJ 1006

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 138101   Accepted: 44225

Description

人生来就有三个生理周期,分别为体力、感情和智力周期,它们的周期长度为23天、28天和33天。每一个周期中有一天是高峰。在高峰这天,人会在相应的方面表现出色。例如,智力周期的高峰,人会思维敏捷,精力容易高度集中。因为三个周期的周长不同,所以通常三个周期的高峰不会落在同一天。对于每个人,我们想知道何时三个高峰落在同一天。对于每个周期,我们会给出从当前年份的第一天开始,到出现高峰的天数(不一定是第一次高峰出现的时间)。你的任务是给定一个从当年第一天开始数的天数,输出从给定时间开始(不包括给定时间)下一次三个高峰落在同一天的时间(距给定时间的天数)。例如:给定时间为10,下次出现三个高峰同天的时间是12,则输出2(注意这里不是3)。

Input

输入四个整数:p, e, i和d。 p, e, i分别表示体力、情感和智力高峰出现的时间(时间从当年的第一天开始计算)。d 是给定的时间,可能小于p, e, 或 i。 所有给定时间是非负的并且小于365, 所求的时间小于21252。 

当p = e = i = d = -1时,输入数据结束。

Output

从给定时间起,下一次三个高峰同天的时间(距离给定时间的天数)。 

采用以下格式: 
Case 1: the next triple peak occurs in 1234 days. 

注意:即使结果是1天,也使用复数形式“days”。

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

Source

Translator

北京大学程序设计实习2007, Xie Di
 
 
这道题目我们可以从周期长度入手,
很容易看出三个周期长度是两两互质的,
于是我们可以考虑中国剩余定理,
我们需要构造一个解满足。
ans%23 = p
ans%28 = e
ans%33 = i
其中p,e,i是输入数据
然后跑一个裸的中国剩余定理就好
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
using namespace std;
const int MAXN=1001;
inline void read(int &n)
{
    char c='+';int x=0;bool flag=0;
    while(c<'0'||c>'9'){c=getchar();if(c=='-')flag=1;}
    while(c>='0'&&c<='9'){x=x*10+(c-48);c=getchar();}
    flag==1?n=-x:n=x;
}
int getgcd(int a,int b)
{
    return b==0?a:getgcd(b,a%b); 
}
int exgcd(int a,int b,int &x,int &y)
{
    if(b==0)
    {
        x=1;
        y=0;
        return a;
    }
    int r=exgcd(b,a%b,x,y);
    int tmp=x;
    x=y;
    y=(tmp-(a/b)*y);
    return r;
}
int crt(int *a,int *m,int num)
{
    int M=1,ans=0;
    for(int i=1;i<=num;i++)
        M*=m[i];
    int x,y;
    for(int i=1;i<=num;i++)
    {
        int nowm=(M/m[i]);
        int remain=exgcd(nowm,m[i],x,y);
        ans=(ans+a[i]*nowm*x)%M;
    }
    return ans;
}
int tl,qg,zs,day;
int now=1;
int a[MAXN];
int m[MAXN];
int main()
{
    ios::sync_with_stdio(0);
    m[1]=23;
    m[2]=28;
    m[3]=33;
    int tot=0;
    while(cin>>a[1]>>a[2]>>a[3]>>day)
    {
        if(a[1]==-1)break;
        int out=crt(a,m,3);
        if(out<=day)
            out+=21252;
        printf("Case %d: the next triple peak occurs in %d days.\n",++tot,out-day);    
    }
    return 0;
}

 

  

 
 
posted @ 2017-08-07 17:04  自为风月马前卒  阅读(492)  评论(4编辑  收藏  举报

Contact with me