Balance

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2
大意:天枰问题,把背包变成零,因为下标不会出现负数,所以重新选择一个平衡点15*25*20=7500
递归方程 : dp[i][k+w[j]*v[i]]+=dp[i-1][j], 输出dp[m][7500],dp[i][j]表示经过加东西之后肯能到达平衡的点。
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
int dp[30][30000];
using namespace std;
int main(){
int w[25],v[25];
int n,m;
while(~scanf("%d%d", &n,&m)){
    for(int i = 1; i <= n; i++)
    scanf("%d",&w[i]);
    for(int i = 1; i <= m; i++)
    scanf("%d",&v[i]);

    memset(dp, 0, sizeof(dp));

    dp[0][7500] = 1;
    for(int i = 1; i <= m; i++){
        for(int j = 1; j <= n; j++){
           for(int k = 0; k <= 15000; k ++){
                dp[i][k+w[j]*v[i]]+=dp[i-1][k];
             }
          }
      }
      printf("%d\n", dp[m][7500]);
    }
    return 0;
}
View Code

 

 
posted @ 2015-03-04 14:54  Painting、时光  阅读(167)  评论(0编辑  收藏  举报