poj3254 Corn Fields

orn Fields
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 17989   Accepted: 9474

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.
题目大意:标1的地能够放牛,0的不能放牛,放的牛不能相邻,问有多少种方案.
分析:状压dp经典题.
   令f[i][j]表示前i行中,第i行的状态为j的方案数,枚举第i-1行的状态k,如果k,j合法,那么f[i][j] += f[i - 1][k].先要预处理出第一行合法的状态.
   小优化:可以将每一行中合法的状态提出来.
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int mod = 100000000;
int n,m,a[20][20],f[13][1 << 13],cnt[20],maxn,ans,sta[1 << 13],tot;

bool check(int x,int y)
{
    if (x & y)
        return false;
    return true;
}

int main()
{
    scanf("%d%d",&n,&m);
    maxn = (1 << m) - 1;
    for (int i = 0; i <= maxn; i++)
    {
        if (i & (i << 1))
            continue;
        sta[++tot] = i;
    }
    for (int i = 1; i <= n; i++)
        for (int j = 1; j <= m; j++)
        {
            scanf("%d",&a[i][j]);
            if (a[i][j] == 0)
                cnt[i] |= (1 << (m - j));
        }
    for (int i = 1; i <= tot; i++)
        if (check(cnt[1],sta[i]))
            f[1][sta[i]] = 1;
    for (int i = 2; i <= n; i++)
        for (int j = 1; j <= tot; j++)
        {
            if (!check(cnt[i - 1],sta[j]))
                continue;
            for (int k = 1; k <= tot; k++)
            {
                if (!check(cnt[i],sta[k]))
                    continue;
                if (sta[k] & sta[j])
                    continue;
                f[i][sta[k]] += f[i - 1][sta[j]];
                f[i][sta[k]] %= mod;
            }
        }
    for (int i = 1; i <= tot; i++)
    {
        ans += f[n][sta[i]];
        ans %= mod;
    }
    printf("%d\n",ans);

    return 0;
}

 

posted @ 2018-02-20 17:41  zbtrs  阅读(144)  评论(0编辑  收藏  举报