poj1523 SPF

SPF
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9616   Accepted: 4334

Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible.

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate.

Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.

Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist.

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.

Sample Input

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets

Source

大致题意:求出给定图中的所有割点和删掉这个点以后形成的连通块的数量.
分析:做tarjan算法,如果当前点是根节点并且儿子数cnt > 1,那么根节点一定是割点,删掉根节点后会形成 cnt个连通块.如果当前点i不是割点并且有cnt个儿子节点的子树中的点没有返祖边到i的祖先上,那么删掉i后就会形成cnt + 1个连通块(祖先那一部分也是一个连通块).因为是连通图,所以只需要在1号点调用一次tarjan算法就可以了.
       这道题输出比较麻烦,最好是将字符串复制到文档里,整理好后再复制到代码中,不然很容易出错.
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int maxn = 10010;

int a,b,n,head[maxn],to[maxn],tot = 1,pre[maxn],low[maxn],dfs_clock,cas,nextt[maxn];
bool use[maxn];
bool flag = false;

struct node
{
    int ans,id;
}e[maxn];

void add(int x,int y)
{
    to[tot] = y;
    nextt[tot] = head[x];
    head[x] = tot++;
}

void tarjan(int u,int fa)
{
    pre[u] = low[u] = ++dfs_clock;
    int cnt = 0;
    for (int i = head[u];i;i = nextt[i])
    {
        int v = to[i];
        if (v == fa)
            continue;
        if (!pre[v])
        {
            tarjan(v,u);
            cnt++;
            if(low[v] < low[u])
                low[u] = low[v];
                if (u == 1 && cnt > 1)
                {
                    e[u].id = 1;
                    e[u].ans = cnt - 1;
                }
                if (u != 1 && low[v] >= pre[u])
                {
                    e[u].id = 1;
                    e[u].ans++;
                }
            }
        else
            low[u] = min(low[u],pre[v]);
    }
}

void init()
{
    n = 0;
    flag = false;
    dfs_clock = 0;
    memset(low,0,sizeof(low));
    memset(pre,0,sizeof(pre));
    memset(e,0,sizeof(e));
    memset(head,0,sizeof(head));
    memset(use,0,sizeof(use));
    tot = 1;
}

int main()
{
    while (scanf("%d",&a) != EOF && a)
    {
        init();
        scanf("%d",&b);
        n = max(n,max(a,b));
        add(a,b);
        add(b,a);
        while (scanf("%d",&a) != EOF && a)
        {
            scanf("%d",&b);
            n = max(n,max(a,b));
            add(a,b);
            add(b,a);
        }
        tarjan(1,-1);
        printf("Network #%d\n",++cas);
        for (int i = 1; i <= n; i++)
            if (e[i].id == 1)
        {
             printf("  SPF node %d leaves %d subnets\n",i,e[i].ans+1);
             flag = true;
        }
        if (flag == false)
            printf("  No SPF nodes\n");
        printf("\n");
    }

    return 0;
}

 

posted @ 2017-12-15 19:38  zbtrs  阅读(229)  评论(0编辑  收藏  举报