poj1006 生理周期

生理周期
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 138947   Accepted: 44597

Description

人生来就有三个生理周期,分别为体力、感情和智力周期,它们的周期长度为23天、28天和33天。每一个周期中有一天是高峰。在高峰这天,人会在相应的方面表现出色。例如,智力周期的高峰,人会思维敏捷,精力容易高度集中。因为三个周期的周长不同,所以通常三个周期的高峰不会落在同一天。对于每个人,我们想知道何时三个高峰落在同一天。对于每个周期,我们会给出从当前年份的第一天开始,到出现高峰的天数(不一定是第一次高峰出现的时间)。你的任务是给定一个从当年第一天开始数的天数,输出从给定时间开始(不包括给定时间)下一次三个高峰落在同一天的时间(距给定时间的天数)。例如:给定时间为10,下次出现三个高峰同天的时间是12,则输出2(注意这里不是3)。

Input

输入四个整数:p, e, i和d。 p, e, i分别表示体力、情感和智力高峰出现的时间(时间从当年的第一天开始计算)。d 是给定的时间,可能小于p, e, 或 i。 所有给定时间是非负的并且小于365, 所求的时间小于21252。 

当p = e = i = d = -1时,输入数据结束。

Output

从给定时间起,下一次三个高峰同天的时间(距离给定时间的天数)。 

采用以下格式: 
Case 1: the next triple peak occurs in 1234 days. 

注意:即使结果是1天,也使用复数形式“days”。

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

Source

Translator

北京大学程序设计实习2007, Xie Di
分析:其实非常显然,这道题是用中国剩余定理做的,而且三个周期是互质的,不用特殊处理.关于中国剩余定理可以看:oi初级数学知识.
      这是我第一次用中国剩余定理做题,也出现了一些问题,答案最后处理出来可能是负数,我们需要不断的加上模数直到变成正数,或者答案小于d,我们也需要累加直到大于d.其实我感觉吧,用扩展欧几里得解出来需要取模的题一般都有可能涉及到负数的情况,例如noip2012同余方程,要讨论一下.
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;

const int mod = 21252;

int d,a[4];
int cnt = 0,ans,M;
int m[4] = {0,23,28,33};

void exgcd(int a,int b,int &x,int &y)
{
    if (!b)
    {
        x = 1;
        y = 0;
        return;
    }
    exgcd(b,a % b,x,y);
    int t = x;
    x = y;
    y = t - (a / b) * y;
    return;
}

void china()
{
    ans = 0,M = 1;
    for (int i = 1; i <= 3; i++)
    M *= m[i];
    for (int i = 1; i <= 3; i++)
    {
        int mi = M / m[i];
        int x,y;
        exgcd(mi,m[i],x,y);
        ans = (ans + a[i] * mi * x) % M;
    }
    if (ans < 0)
    ans += M;
}

int main()
{
    while (scanf("%d%d%d%d",&a[1],&a[2],&a[3],&d) && a[1] >= 0 && a[2] >= 0 && a[3] >= 0 && d >= 0)
    {
        cnt++;
        china();
        if (ans <= d)
        ans += mod;
        ans -= d;
        printf("Case %d: the next triple peak occurs in %d days.\n",cnt,ans);
    }
    
    return 0;
 } 

 

posted @ 2017-09-08 21:20  zbtrs  阅读(496)  评论(0编辑  收藏  举报