poj3292 Semi-prime H-numbers

Semi-prime H-numbers
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9873   Accepted: 4404

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21 
85
789
0

Sample Output

21 0
85 5
789 62

Source

分析:一开始把题目看错了,打了个线性筛WA了,其实比筛法更简单,只需要按照题目说的那样枚举一下标记一下就好了.
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;

const int maxn = 1000001;
int flag[maxn],sum[maxn],h;

void init()
{
    for (int i = 5; i <= maxn; i += 4)
    for (int j = 5; j <= maxn; j += 4)
    {
        int t = i * j;
        if (t > maxn)
        break;
        if (!flag[i] && !flag[j])
        flag[t] = 1;
        else
        flag[t] = -1;
    }
    int cnt = 0;
    for (int i = 1; i <= maxn; i++)
    {
        if (flag[i] == 1)
        cnt++;
        sum[i] = cnt;
    }
}

int main()
{
    init();
    while (scanf("%d",&h) && h != 0)
        printf("%d %d\n",h,sum[h]);
    
    
    return 0;
}

 

 
posted @ 2017-09-08 17:54  zbtrs  阅读(144)  评论(0编辑  收藏  举报