树 List Leaves 【用数组模拟了树状结构建树+搜索叶子节点+按照特殊规律输出每个叶子节点】

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5

分析:数据量很小,怎么写都过啊。于是我用结构体数组来模拟建立树状结构。然后找到每个叶子节点,但输出有要求。先输出深度小的节点,深度相同的叶子节点
先输出靠左的叶子节点,再输出靠右的叶子节点。
样例建树后的样子
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <ctype.h>
#include <queue>
#include <algorithm>

using namespace std;

struct node
{
    int ll;
    int rr;
    int data;
    int dep;
    int dfn;
}q[20];

struct N
{
    int num;
    int dep;
    int dfn;
    bool operator<(const N &dd)const{
        if(dep==dd.dep)
            return dd.dfn<dfn;
        else
            return dd.dep<dep;
    }
};

int cnt;
void dfs_leaf(int root, int deep)
{
    if(q[root].ll==-1 && q[root].rr==-1)
        return;
    if(q[root].ll!=-1){
        int v=q[root].ll;
        q[v].dep=deep+1;
        q[v].dfn=cnt++;
        dfs_leaf(v, deep+1);
    }
    if(q[root].rr!=-1){
        int v=q[root].rr;
        q[v].dep=deep+1;
        q[v].dfn=cnt++;
        dfs_leaf(v, deep+1);
    }
}

int main()
{
    int n; scanf("%d%*c", &n);
    int i, j, k;
    char a[5], b[5];
    for(i=0; i<n; i++){
        scanf("%s %s", a, b);
        if(a[0]=='-'){
            q[i].ll=-1;
        }else{
            q[i].ll=a[0]-48;
        }

        if(b[0]=='-'){
            q[i].rr=-1;
        }else{
            q[i].rr=b[0]-48;
        }//模拟每一个树节点
    }//建树完成
    bool f[20];//标记每一个节点是不是儿子
    memset(f, false, sizeof(f));
    for(i=0; i<n; i++){
        if(q[i].ll!=-1){
            f[q[i].ll]=true;
        }
        if(q[i].rr!=-1){
            f[q[i].rr]=true;
        }
    }
    int root;
    for(i=0; i<n; i++){
        if(f[i]==false){
            root=i; break;
        }
    }
   //printf("root = %d\n", root);

    cnt=1;
    q[root].dfn=0; q[root].dep=0;
    dfs_leaf(root, 0);

    priority_queue<N>que;
    N cur;
    for(i=0; i<n; i++){
        if(q[i].ll==-1&&q[i].rr==-1){
            cur.num=i;
            cur.dep=q[i].dep;
            cur.dfn=q[i].dfn;
            que.push(cur);
            //printf("%d节点:深度%d 次序%d\n", i, q[i].dep, q[i].dfn);
        }
    }

    bool z=false;
    while(!que.empty()){
        if(z==false){
            printf("%d", que.top().num); z=true; que.pop();
        }
        else{
            printf(" %d", que.top().num); que.pop();
        }
    }printf("\n");
    return 0;
}

 

 
posted @ 2015-09-16 16:30  我喜欢旅行  阅读(567)  评论(0编辑  收藏  举报