poj 2208 Pyramids

Pyramids
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2118   Accepted: 696   Special Judge

Description

Recently in Farland, a country in Asia, a famous scientist Mr. Log Archeo has discovered ancient pyramids. But unlike those in Egypt and Central America, they have triangular (not rectangular) foundation. That is, they are tetrahedrons in mathematical sense. In order to find out some important facts about the early society of the country (it is widely believed that the pyramid sizes are in tight connection with Farland ancient calendar), Mr. Archeo needs to know the volume of the pyramids. Unluckily, he has reliable data about their edge lengths only. Please, help him!

Input

The file contains six positive integer numbers not exceeding 1000 separated by spaces, each number is one of the edge lengths of the pyramid ABCD. The order of the edges is the following: AB, AC, AD, BC, BD, CD.

Output

A real number -- the volume printed accurate to four digits after decimal point.

Sample Input

1000 1000 1000 3 4 5

Sample Output

1999.9938
#include <iostream>
#include <cmath>
using namespace std;

int main()
{
double a, b, c, d, e, f;
while (scanf("%lf %lf %lf %lf %lf %lf", &a, &b, &c, &d, &e, &f) != EOF) {
double ang1, ang2, ang3, ang;
ang1 = acos((b*b+c*c-f*f)/(2*b*c));
ang2 = acos((a*a+c*c-e*e)/(2*a*c));
ang3 = acos((a*a+b*b-d*d)/(2*a*b));
ang = (ang1+ang2+ang3)/2;
double res = (1.0/3.0)*a*b*c*sqrt(sin(ang)*sin(ang-ang1)*sin(ang-ang2)*sin(ang-ang3));
printf("%.4lf\n", res);
}
return 0;
}

posted @ 2011-11-22 08:41  w0w0  阅读(184)  评论(0编辑  收藏  举报