4 Values whose Sum is 0

Time Limit:
15000ms
Memory limit:
228000kB
题目描述
The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
输入
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .
输出
For each input file, your program has to write the number quadruplets whose sum is zero.
样例输入
6
-45 22 42 -16-41 -27 
56 30 -36   53 -37 77
-36 30 -75 -46 26 -38 
-10 62-32 -54 -6 45
样例输出
5
提示
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

解答:#include <iostream>
#include <algorithm>
#define N 4000
using namespace std;
int a[N],b[N],c[N],d[N],ab[N*N],cd[N*N];
int main()
{
  
    int i,j,n,pab,pcd;
    while(cin>>n)
    {
  pab=pcd=0;
   for(i=0;i<n;i++)
   {
      //cin>>a[i]>>b[i]>>c[i]>>d[i]; 
   scanf("%d %d %d %d",&a[i],&b[i],&c[i],&d[i]); 
   }
   for(i=0;i<n;i++)
      for(j=0;j<n;j++)
   {
    ab[pab++]=a[i]+b[j];
    cd[pcd++]=-(c[i]+d[j]);
   }
   sort(cd,cd+n*n);//是数组的起始地址与最后地址
  
   int k,ans=0;
   for(i=0;i<pab;i++)
   {
      int l=0,r=pcd-1,mid;
   while(l<=r)
   {
   mid=(l+r)/2; 
   if(ab[i]==cd[mid])
   {
      ans++;//下一句怎么写
      for(k=mid+1;k<pcd;k++)
      if(ab[i]==cd[k]) ans++;
      else break;
      for(k=mid-1;k>=0;k--)
      if(ab[i]==cd[k]) ans++;
      else break; //因为已经排好序了,所以这里只要找最靠近Mid的数,不用continue,否则超时
      break;
   }
   else if(ab[i]<cd[mid]) r=mid-1;
   else l=mid+1; 
   }  
   } 
   cout<<ans<<endl; 
 }
   // system("pause");
    return 0;
}

posted on 2010-04-09 20:49  蓝牙  阅读(663)  评论(0编辑  收藏  举报