POJ 3349 Snowflake Snow Snowflakes

Snowflake Snow Snowflakes
Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 27086   Accepted: 7138

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.
题目大意:给定雪花的六条边长,不论顺序,只要其中有两个雪花六条边的长度都相等,那么输出“Twin snowflakes found”,否则输出“No two snowflakes are alike.”
解题方法:哈希表拉链法,如果没有和当前相同的雪花则存入哈希表,否则找到相同的雪花。
#include <stdio.h>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
using namespace std;

typedef struct node
{
    int num[6];
    node *next;
    node()
    {
        for (int i = 0; i < 6; i++)
        {
            num[i] = -1;
        }
        next = NULL;
    }
}Node;

int main()
{
    int n, sum, num[6];
    Node nodes[10000];
    bool flag = false;
    scanf("%d", &n);
    for (int i = 0; i < n; i++)
    {
        sum = 0;
        for (int j = 0; j < 6; j++)
        {
            scanf("%d", &num[j]);
            sum += num[j];
        }
        if (!flag)
        {
            sort(num, num + 6);
            Node *pnode = &nodes[sum % 10000];
            while(pnode->next != NULL && !flag)
            {
                pnode = pnode->next;
                for (int j = 0; j < 6; j++)
                {
                    if (pnode->num[j] != num[j])
                    {
                        break;
                    }
                    else
                    {
                        if (pnode->num[j] == num[j] && j == 5)
                        {
                            flag = true;
                        }
                    }
                }
            }
            Node *newnode = new Node;
            for (int j = 0; j < 6; j++)
            {
                newnode->num[j] = num[j];
            }
            pnode->next = newnode;
        }
    }
    if (flag)
    {
        printf("Twin snowflakes found.\n");
    }
    else
    {
        printf("No two snowflakes are alike.\n");
    }
    return 0;
}

 

posted on 2013-08-04 14:56  lzm风雨无阻  阅读(719)  评论(0编辑  收藏  举报

导航