Uva 642 - Word Amalgamation sort qsort

 Word Amalgamation 

In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.

 

Input 

The input file contains four parts:

 

1.
a dictionary, which consists of at least one and at most 100 words, one per line;
2.
a line containing XXXXXX, which signals the end of the dictionary;
3.
one or more scrambled `words' that you must unscramble, each on a line by itself; and
4.
another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercaseX's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.

 

Output 

For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.

 

Sample Input 

 

tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX

 

Sample Output 

score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******

 

 sort代码

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
char word[100][7];
char* dic[100];
char* seq[100];
char str[7];

bool compare(char *p1, char *p2)
{
	return strcmp(p1,p2)<0;
}
int main()
{
	int n ;
	for (n = 0; scanf("%s", word[n]) && strcmp(word[n], "XXXXXX") != 0; n++);
	for (int i=0; i < n; i++)
		dic[i] = word[i];
	sort(dic,dic+n,compare);
	for (int i = 0; i < n; i++)
	{
		seq[i] = (char *)malloc(strlen(dic[i])+1);
		strcpy(seq[i],dic[i]);
		sort(seq[i],seq[i]+strlen(seq[i]));
	}
	while (scanf("%s", str) && strcmp(str, "XXXXXX") != 0)
	{
		int found = 0;
		sort(str,str+strlen(str));
		for (int i = 0; i < n;i++)
			if (strcmp(str, seq[i]) == 0)
			{
				found = 1;
				printf("%s\n",dic[i]);
			}
		if (found == 0)
			printf("NOT A VALID WORD\n");
		printf("******\n");
	}
	return 0;
}

  用qsort代码

#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std;
char word[100][7];
char seq[100][7];
char str[7];
int comp_char(const void * p1, const void * p2)
{
	return *(char *)p1 - *(char *)p2;
}
int compare(const void *p1, const void *p2)
{
	return strcmp((char *)p1, (char *)p2);
}
int main()
{
	int n;
	for (n = 0; scanf("%s", word[n]) && strcmp(word[n], "XXXXXX") != 0; n++);
	qsort(word,n,sizeof(word[0]),compare);
	for (int i = 0; i < n; i++)
	{
		strcpy(seq[i], word[i]);
		qsort(seq[i], strlen(seq[i]),sizeof(char),comp_char);
	}
	while (scanf("%s", str) && strcmp(str, "XXXXXX") != 0)
	{
		int found = 0;
		qsort(str, strlen(str),sizeof(char),comp_char);
		for (int i = 0; i < n; i++)
		if (strcmp(str, seq[i]) == 0)
		{
			found = 1;
			printf("%s\n", word[i]);
		}
		if (found == 0)
			printf("NOT A VALID WORD\n");
		printf("******\n");
	}
	return 0;
}

  qsort可以对2维数组进行排序,因为它可以调换任意大小的内存块的顺序(第三个参数指定),sort只能对一维数组或者容器进行排序,因为对其解引用时必须是一个左值。

  另一个注意点就是cmp函数比较时qsort用“-”,而sort用”>”。

sort函数要求比较函数是strict weak ordering的,否则会出现assertion error: Invalid operator<,而strict weak ordering必须满足三个条件:

1) Strict: pred (X, X) is always false.  X跟X自己比为false

2) Weak: If ! pred (X, Y) && !pred (Y, X), X==Y. 当X<Y和Y<X都不成立时,X等于Y

3)Ordering: If pred (X, Y) && pred (Y, Z), then pred (X, Z). 当X<Y,Y<Z时,X<Z成立,即排序的一个传递性。

posted on 2014-12-06 20:45  lakeone  阅读(428)  评论(0编辑  收藏  举报

导航