POJ 2184 Cow Exhibition(01背包)

Cow Exhibition
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6899   Accepted: 2437

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much
fun..."
- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input

* Line 1: A single integer N, the number of cows

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.

Source

 
 

给出num(num<=100)头奶牛的S和F值(-1000<=S,F<=1000),要求在这几头奶牛中选出若干头,使得在其总S值TS和总F值TF均不为负的前提下,求最大的TS+TF值

可以把S当体积,F当价值做01背包。但是注意是S可为负,所以整体加100000,然后要注意DP顺序,S为负是要顺序,为正时逆序。

还有就是注意DP时的范围,凡是可能影响的都要包括。

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
const int MAXN=110;
int dp[200010];
int value[MAXN];
int weight[MAXN];
int nKind;
int main()
{
    int k=100000;
    while(scanf("%d",&nKind)!=EOF)
    {
        for(int i=0;i<nKind;i++)
        {
            scanf("%d%d",&value[i],&weight[i]);
        }
        for(int i=0;i<=200000;i++)dp[i]=-INF;
        dp[k]=0;
        for(int i=0;i<nKind;i++)
        {
            if(value[i]>0)//正的是逆序
            {
                for(int j=200000;j>=value[i];j--)//注意范围
                  if(dp[j-value[i]]>-INF)
                    dp[j]=max(dp[j],dp[j-value[i]]+weight[i]);
            }
            else//负的是顺序
            {
                for(int j=0;j<=200000+value[i];j++)//注意范围
                  if(dp[j-value[i]]>-INF)
                    dp[j]=max(dp[j],dp[j-value[i]]+weight[i]);
            }
        }
        int ans=0;
        for(int i=100000;i<=200000;i++)
            if(dp[i]>=0&&dp[i]+i-100000>ans)
                ans=dp[i]+i-100000;
        printf("%d\n",ans);
    }
    return 0;
}

 

posted on 2012-09-14 14:48  kuangbin  阅读(2576)  评论(0编辑  收藏  举报

导航

JAVASCRIPT: