junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Watch The Movie

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 7559    Accepted Submission(s): 2413


Problem Description
New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some movies and watch with her tonight. Her grandfather gave them L minutes to watch the cartoon. After that they have to go to sleep.
DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play over. If a movie DuoDuo choice to watch she won’t stop until it goes to end.
But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they cost not more then L.
How clever you are! Please help DuoDuo’s uncle.
 

Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case:
The first line is: N(N <= 100),M(M<=N),L(L <= 1000)
N: the number of DVD that DuoDuo want buy. 
M: the number of DVD that the shop can sale.
L: the longest time that her grandfather allowed to watch.
The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.
 

Output
Contain one number. (It is less then 2^31.)
The total value that DuoDuo can get tonight.
If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.
 

Sample Input
1 3 2 10 11 100 1 2 9 1
 

Sample Output
3
 

Source

从N部电影选择M部,使其价值最大且总时长不超过L,因为必须选够M部不能多也不能少,所以是必须装满的二维01背包,dp[i][j] 表示选择i部电影不超过j时间获得的最大价值,容易得出状态转移方程:dp[i][j] = max(dp[i][j], dp[i-1][j-c[k]]+v[k])


# include <stdio.h>
# include <string.h>
int max(int a, int b){return a>b?a:b;}
int main()
{
    int t, n, m, l, i, j, k, imax, dp[101][1001], v[101], c[101];
    scanf("%d",&t);
    while(t--)
    {
        memset(dp, -1, sizeof(dp)); //必须装满,初始化为负。
        scanf("%d%d%d",&n,&m,&l);
        for(i=0; i<n; ++i)
            scanf("%d%d",&c[i],&v[i]);
        for(i=0; i<=l; ++i)
            dp[0][i] = 0;
        for(i=0; i<n; ++i)
            for(j=m; j>=1; --j)
                for(k=l; k>=c[i]; --k)
                {
                    if(dp[j-1][k-c[i]] == -1)
                        continue;
                    else if(dp[j-1][k-c[i]]+v[i] > dp[j][k])
                        dp[j][k] = dp[j-1][k-c[i]]+v[i];
                }
        if(dp[m][l] == -1 )
            dp[m][l] = 0;
        printf("%d\n",dp[m][l]);
    }
    return 0;
}




posted on 2017-01-15 13:43  junior19  阅读(89)  评论(0编辑  收藏  举报