Proxy(2016山东省省赛C)(最短路)(spfa)

问题 C: Proxy

时间限制: 2 Sec  内存限制: 128 MB
提交: 17  解决: 5
[提交][状态][讨论版]

题目描述

Because of the GFW (Great Firewall), we cannot directly visit many websites, such as Facebook, Twitter, YouTube, etc. But with the help of proxy and proxy server, we can easily get to these website.
You have a list of several proxy servers, some of them can be connected directly but others can’t. But you can visit proxy servers through other proxy server by a one-way connection.
As we all know, the lag of internet visit will decide our feelings of the visit. You have a very smart proxy software which will find the least lag way to reach the website once you choose a directly reachable proxy server.
You know the lag of every connection. The lag of your visit is the all the lags in your whole connection. You want to minimize the lag of visit, which proxy server you will choose?

输入

Multiple test cases, the first line is an integer T (T <= 100), indicating the number of test cases.
The first line of each test case is two integers N (0 <= N <= 1000), M (0 <= M <= 20000). N is the number of proxy servers (labeled from 1 to N). 0 is the label of your computer and (N+1) is the label of the server of target website.
Then M lines follows, each line contains three integers u, v, w (0 <= u, v <= N + 1, 1 <= w <= 1000), means u can directly connect to v and the lag is w.

输出

An integer in one line for each test case, which proxy server you will choose to connect directly. You can only choose the proxy server which can be connected directly from your computer.
If there are multiple choices, you should output the proxy server with the least label. If you can’t visit the target website by any means, output “-1” (without quotes). If you can directly visit the website and the lag is the least, output “0” (without quotes).

样例输入

4
3 6
0 1 10
1 2 1
2 4 4
0 3 2
3 2 1
3 4 7
2 4
0 2 10
0 1 5
1 2 4
2 1 7
1 3
0 2 1
0 1 2
1 2 1
1 3
0 2 10
0 1 2
1 2 1

样例输出

3
-1
0
1
【分析】要是只求最短距离那还简单,Spfa就挺好,但是要求输出你走的第一个点就有点麻烦,我们可以用一个pre数组,pre[i]存的是当走到i节点时,从0到i的
最短路中与0相连的那个节点,这样在找最短路时就可以灵活的更新了。
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <climits>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <vector>
#include <list>
#define mod 1000000007
#define inf 0x3f3f3f3f
#define pi acos(-1.0)
using namespace std;
typedef long long ll;
#define RANGE 1005
#define MAX 0x3f3f3f3f
int cost[RANGE][RANGE];
int d[RANGE];
bool used[RANGE];
int n,m;
int pre[1005];
void spfa(int s)
{
    int i,j,now;
    for(i=0;i<=n+1;i++)
    {
        d[i]=MAX;
        used[i]=false;
    }
    int flag=0;
    for(i=0;i<=n+1;i++)
    {
        if(cost[0][i]<MAX)pre[i]=i;//初始化pre数组
    }
    used[s]=true;
    d[s]=0;
    queue<int> q;
    q.push(s);
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        for(i=0;i<=n+1;i++)
        {
            if(d[i]>d[now]+cost[now][i])
            {
                d[i]=d[now]+cost[now][i];
                if(used[i]==0)
                {
                    if(now!=0)pre[i]=pre[now];
                    used[i]==true;
                    q.push(i);
                }
            }
            if(d[i]==d[now]+cost[now][i])
            {
                    if(now!=0)pre[i]=min(pre[i],pre[now]);
            }
        }
    }
}
int main()
{
    int i,j,a,b,c;
    int we;
    scanf("%d",&we);
    while(we--)
    {scanf("%d%d",&n,&m);
        if(!n&&!m) break;
        for(i=0;i<=n+1;++i)
        {
            for(j=0;j<=i;j++)
            {
                if(i==j)  cost[i][j]=0;
                else  cost[i][j]=cost[j][i]=MAX;
            }
        }
        for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            cost[a][b]=c;
        }
        spfa(0);
        if(d[n+1]<MAX)
        {
            if(pre[n+1]==n+1)printf("0\n");
            else printf("%d\n",pre[n+1]);
        }
        else printf("-1\n");
    }
    return 0;
}
View Code

 


posted @ 2016-07-31 16:42  贱人方  阅读(353)  评论(0编辑  收藏  举报