代码改变世界

杭电 2829 蛋疼的动态规划

2012-02-27 21:34  javaspring  阅读(177)  评论(0编辑  收藏  举报

           话说这道题是一道惊天地泣鬼神的动态规划题,在调试了n久之后,蓦然发现系统自带的INT_MAX不能和整数相加。。。。这让我情何以堪!!!!!题目:

Lawrence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1032    Accepted Submission(s): 463


Problem Description
T. E. Lawrence was a controversial figure during World War I. He was a British officer who served in the Arabian theater and led a group of Arab nationals in guerilla strikes against the Ottoman Empire. His primary targets were the railroads. A highly fictionalized version of his exploits was presented in the blockbuster movie, "Lawrence of Arabia".

You are to write a program to help Lawrence figure out how to best use his limited resources. You have some information from British Intelligence. First, the rail line is completely linear---there are no branches, no spurs. Next, British Intelligence has assigned a Strategic Importance to each depot---an integer from 1 to 100. A depot is of no use on its own, it only has value if it is connected to other depots. The Strategic Value of the entire railroad is calculated by adding up the products of the Strategic Values for every pair of depots that are connected, directly or indirectly, by the rail line. Consider this railroad: 


Its Strategic Value is 4*5 + 4*1 + 4*2 + 5*1 + 5*2 + 1*2 = 49.

Now, suppose that Lawrence only has enough resources for one attack. He cannot attack the depots themselves---they are too well defended. He must attack the rail line between depots, in the middle of the desert. Consider what would happen if Lawrence attacked this rail line right in the middle: 

The Strategic Value of the remaining railroad is 4*5 + 1*2 = 22. But, suppose Lawrence attacks between the 4 and 5 depots: 

The Strategic Value of the remaining railroad is 5*1 + 5*2 + 1*2 = 17. This is Lawrence's best option.

Given a description of a railroad and the number of attacks that Lawrence can perform, figure out the smallest Strategic Value that he can achieve for that railroad. 
 

Input
There will be several data sets. Each data set will begin with a line with two integers, n and m. n is the number of depots on the railroad (1≤n≤1000), and m is the number of attacks Lawrence has resources for (0≤m<n). On the next line will be n integers, each from 1 to 100, indicating the Strategic Value of each depot in order. End of input will be marked by a line with n=0 and m=0, which should not be processed.
 

Output
For each data set, output a single integer, indicating the smallest Strategic Value for the railroad that Lawrence can achieve with his attacks. Output each integer in its own line.
 

Sample Input
4 1 4 5 1 2 4 2 4 5 1 2 0 0
 

Sample Output
17 2
 

ac代码:

#include <iostream>
#include <cstdio>
#include <climits>
#include <string.h>
using namespace std;
#define M 1010
#define MAX 2000000000
int value[M][M];//存储从前面某个点到后面某个点的权值
int leftpoint[M][M];//存储当有j个点,i颗炸弹时,所炸的直线的左端点的值
int num[M];
int a[M];//临时数组
int dp[M][M];//最后的值数组
int main(){
 // freopen("1.txt","r",stdin);
  int n,m;
  while(scanf("%d%d",&n,&m),n,m){
	//init();
    for(int i=1;i<=n;++i)
		scanf("%d",&num[i]);
	for(int i=1;i<=n;++i){
		a[i]=num[i];
		for(int j=i+1;j<=n;++j){
		  value[i][j]=value[i][j-1]+(a[i]*num[j]);
		  a[i]+=num[j];
		}
	}
	for(int i=1;i<=n;++i){
	  leftpoint[i][n+1]=n;
	  leftpoint[0][i]=1;
	  dp[0][i]=value[1][i];
	}
	for(int i=1;i<=m;++i){
		for(int j=n;j>=i;--j){
		  dp[i][j]=MAX;
		  for(int k=leftpoint[i-1][j];k<=leftpoint[i][j+1];++k){
			  if(k<j&&dp[i][j]>dp[i-1][k]+value[k+1][j]){
			    dp[i][j]=dp[i-1][k]+value[k+1][j];
				leftpoint[i][j]=k;
			}
		  }
		}
	}
	printf("%d\n",dp[m][n]);
  }
  return 0;
}