POJ 2528 Mayor's posters (线段树)

Mayor's posters
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 32200   Accepted: 9347

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

Source

 
 
题意:有一块足够长的墙了给竞选人贴海报,后贴的可能会把衣面贴的给覆盖掉,问最有多少不同的海报是能看到的。

思路:(没学过什么啊离散化,所以又是看了别的人报告才做的 不过也算是学习了)
离散化 我现在对他的初步理解是 因为给的范围无限大或过大无法用数组直接表示,所以进行转换
eg 范围[1,6] [1.7] [2,10] [8 18] 将各点排序
1 1 2 6 7 8 10 18   离散后对应的坐标为
  2 3 4 5 6  7    再根据原来的点把它们对应起来,则离散后坐标为
[1,3] [1,4] [2,6] [5,7]
求解这题的方法 是从后往前贴 如果发现这块区域被完全覆盖了,那就返回。
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

#define L(rt) (rt<<1)
#define R(rt) (rt<<1|1)

const int N=100010;     //注意范围,否则RE

int flag;

struct Tree{
    int l,r;
    bool vis;   //vis 是这块区域是否完全被覆盖
}tree[N<<2];

struct Point{
    int id,x;
}post[N<<2];

int cmp1(Point a,Point b){
    return a.x<b.x;
}

int cmp2(Point a,Point b){
    if(a.id==b.id)
        return a.x<b.x;
    return a.id>b.id;
}

void PushUp(int rt){
    tree[rt].vis=tree[L(rt)].vis && tree[R(rt)].vis;
}

void build(int L,int R,int rt){
    tree[rt].l=L;
    tree[rt].r=R;
    tree[rt].vis=0;
    if(tree[rt].l==tree[rt].r)
        return ;
    int mid=(L+R)>>1;
    build(L,mid,L(rt));
    build(mid+1,R,R(rt));
}

void query(int L,int R,int rt){
    if(tree[rt].vis)
        return ;
    if(tree[rt].l==L && tree[rt].r==R){
        tree[rt].vis=1;
        flag=1;
        return ;
    }
    int mid=(tree[rt].l+tree[rt].r)>>1;
    if(R<=mid)
        query(L,R,L(rt));
    else if(L>=mid+1)
        query(L,R,R(rt));
    else{
        query(L,mid,L(rt));
        query(mid+1,R,R(rt));
    }
    PushUp(rt);
}

int main(){

    //freopen("input.txt","r",stdin);

    int t,n;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i=0;i<2*n;i+=2){
            scanf("%d%d",&post[i].x,&post[i+1].x);
            post[i].id=post[i+1].id=i;
        }
        sort(post,post+2*n,cmp1);
        int tot=0,pre=0;
        for(int i=0;i<2*n;i++){     //离散化,
            if(post[i].x==pre)
                post[i].x=tot;
            else{
                pre=post[i].x;
                post[i].x=++tot;
            }
        }
        build(1,2*n,1);
        sort(post,post+2*n,cmp2);     //排序,从后往前贴
        int ans=0;
        for(int i=0;i<2*n;i+=2){
            int l=post[i].x;
            int r=post[i+1].x;
            flag=0;
            query(l,r,1);
            if(flag)
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

 

posted @ 2013-04-25 09:02  Jack Ge  阅读(2280)  评论(0编辑  收藏  举报