Live2d Test Env

HDU3853LOOPS (师傅逃亡系列•三)(基础概率DP)

Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl). 

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS. 

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)! 
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS. 




Input

The first line contains two integers R and C (2 <= R, C <= 1000). 

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces. 

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them). 

You may ignore the last three numbers of the input data. They are printed just for looking neat. 

The answer is ensured no greater than 1000000. 

Terminal at EOF 

Output

A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS. 

Sample Input

2 2
0.00 0.50 0.50    0.50 0.00 0.50
0.50 0.50 0.00    1.00 0.00 0.00

Sample Output

6.000

题意:

你知道,师傅经常被抓,这次又被抓到一个矩阵里面,最开始他在Map[1][1],出口在Map[n][m];每一次他会消耗两颗神丹,然后每一个格子,有一定概率留在原地,有一定概率向下走一格,有一定概率向右走一格。。。求师傅逃出去的神丹消耗期望。

思路:

这次的逃亡很好想,没有前两次那样需要逆推或者求公式。

 

#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
double dp[1010][1010],a[1010][1010][3];
int main()
{
    int n,m,i,j,k;
    while(~scanf("%d%d",&n,&m)){
        for(i=1;i<=n;i++)
         for(j=1;j<=m;j++)
          for(k=0;k<3;k++)
           scanf("%lf",&a[i][j][k]);
        memset(dp,0,sizeof(dp));
        for(i=n;i>=1;i--) 
         for(j=m;j>=1;j--)
         {
              if(fabs(1-a[i][j][0])<1e-7)//停留原地的概率为1  
                    continue;  
             dp[i][j]=(dp[i][j+1]*a[i][j][1]+dp[i+1][j]*a[i][j][2]+2)/(1.0-a[i][j][0]); 
         }
        printf("%.3f\n",dp[1][1]);
    }return 0;
}

 

posted @ 2017-12-14 20:53  nimphy  阅读(733)  评论(1编辑  收藏  举报