IDEA安装Lombok插件失败的解决方案

作者:13
GitHub:https://github.com/ZHENFENG13
版权声明:本文为原创文章,未经允许不得转载。

Lombok简介

Lombok是Java语言的实用工具,确切的说,应该说是一个很好用的插件,对,插件!可以用来帮助开发人员消除Java代码的冗长,尤其是对于简单的Java对象(POJO),它通过注解实现这一目的,而不是一大段一大段的Java方法。

Project Lombok makes java a spicier language by adding 'handlers' that know how to build and compile simple, boilerplate-free, not-quite-java code.

这里引用GitHub上Lombok仓库官方的一段描述:

lombok项目通过增加处理程序使我们的java语言更加刺激(简洁和快速)。

OK,简介到此为止,本文并不是Lombok插件的使用教程,因此简单的介绍一下即可。

问题描述

通过标题大致也能够知道这次十三遇到的问题了,就是IDEA编辑器无法正常下载安装Lombok插件,当时的情形如下:

download-lombok

在IDEA的Plugins界面搜索插件并下载,但是始终没有任何反应,在半分钟左右的请求等待后IDEA编辑器中直接出现了错误提示弹窗,如下:

faild-download

通过上图可以看到,提示也很清楚,就是无法下载!之后又把这个过程反复尝试了有三次,但是得到的结果都是相同的,之后又尝试了其他的方案,但是都无法正常安装这个插件,具体原因不太清楚,但是估计与网络有很大的关系,可能是被墙了,或者是刚好那天网络发神经,总之就是无论如何都安装不了这个插件。

解决方案

虽然不知道是怎么回事,但是以十三的性格来说,出了问题肯定是会打破砂锅问到底,一定要找到解决方法的。OK,其他的尝试方法就不在本文里面多提了,直接讲一下最终的解决方案吧。

由于无法通过插件仓库下载安装,于是想着通过本地下载并install的方式来把Lombok安装到IDEA编辑器中,过程中也遇到了一些小问题,比如不知道在哪里下载安装包,比如版本号冲突无法安装等等,但是都一一解决。

整个过程就是:下载插件包-->本地install即可。

如果你也遇到了网络问题而导致无法正常安装Lombok插件,可以尝试一下十三的这个教程,亲测可用。

安装过程

1.首先找到插件包

插件包可以在两个地方下载,分别是IDEA的官方插件仓库和GitHub里lombok-intellij-plugin仓库中的release包。

地址分别是:http://plugins.jetbrains.com/plugin/6317-lombok-plugin,网址打开后可以看到各个版本信息:

idea-lombok-plugin

https://github.com/mplushnikov/lombok-intellij-plugin/releases,网址打开后同样可以看到插件的版本信息:

github-idea-lombok-plugin

这里的版本信息有什么用呢?肯定是对应IDEA编辑器的版本了,不同版本之间是无法安装的。

2.之后是确认IDEA的版本

打开IDEA的安装目录可以看到IDEA的版本信息,如图所示:

idea-version

可以看到十三安装的IDEA版本为2017.3.3,因此需要安装对应的Lombok插件版本也是2017.3.3。

3.下载

这一步就不用细讲了,在前文提到的仓库中找到对应版本的文件,点击下载即可,比如我的版本是2017.3.3,那我就下载lombok-plugin-0.16-2017.3.3.zip文件就可以了。

4.安装

依次进入IDEA-->Settings/Preferences-->Plugins

install-from-disk

在Plugins面板中有'install from disk'按钮,点击后选择下载的lombok-plugin-0.16-2017.3.3.zip文件即可,安装成功,过程如下:

install-from-disk

总结

十三总结这篇文章的原因,是因为在遇到这个安装问题后,也曾经尝试在网上找答案,但是没有找到,因此就自己整理了这篇文章,希望以后碰到类似问题的朋友可以很快的解决掉这种小问题。

首发于我的个人博客.

至此,无法通过Browse Repositories安装Lombok插件的问题彻底解决,如果你也遇到了网络问题而导致无法正常安装Lombok插件,可以尝试一下十三使用的安装过程,亲测可用,可以的话记得五星好评。

相关文章:
Plugin 'Lombok Plugin' is incompatible with this installation
如何查看IntelliJ IDEA的版本信息

end

posted @ 2018-06-05 08:37 涵s 阅读(...) 评论(...) 编辑 收藏