Broken Keyboard

problem

You’re typing a long text with a broken keyboard. Well it’s not so badly broken. The only problem with the keyboard is that sometimes the “home” key or the “end” key gets automatically pressed (internally). You’re not aware of this issue, since you’re focusing on the text and did not even turn on the monitor! After you finished typing, you can see a text on the screen (if you turn on the monitor). In Chinese, we can call it Beiju. Your task is to find the Beiju text.

Input

There are several test cases. Each test case is a single line containing at least one and at most 100,000 letters, underscores and two special characters ‘[’ and ‘]’. ‘[’ means the “Home” key is pressed internally, and ‘]’ means the “End” key is pressed internally. The input is terminated by end-of-file (EOF)

Output

For each case, print the Beiju text on the screen.

Sample Input

This_is_a_[Beiju]_text

[[]][][]Happy_Birthday_to_Tsinghua_University

Sample Output

BeijuThis_is_a__text

Happy_Birthday_to_Tsinghua_University

 

 

 

 

#include<iostream>
#include<cstring>
using namespace std;
char a[101000],b[101000];
int main()
{
    while(cin>>a)
    {
        int len=strlen(a),i,j;
        for(i=0;i<len;i++)
        {
            if(a[i]=='['||a[i]==']')
            b[i]='\0';
            else b[i]=a[i];
        }
        b[len]='\0';
        for(j=len-1;j>=0;j--)
        {
            if(a[j]=='[')
            cout<<b+j+1;
        }
        if(!(a[0]=='['||a[0]==']'))
        cout<<b;
        for(j=0;j<len;j++)
        {
            if(a[j]==']')
            cout<<b+j+1;
        }
        cout<<endl;
    }
    return 0;
}

 

posted @ 2017-07-23 10:26  干掉学霸我称王  阅读(366)  评论(0编辑  收藏  举报