【POJ 2484】A Funny Game

Description

Alice and Bob decide to play a funny game. At the beginning of the game they pick n(1 <= n <= 10 6) coins in a circle, as Figure 1 shows. A move consists in removing one or two adjacent coins, leaving all other coins untouched. At least one coin must be removed. Players alternate moves with Alice starting. The player that removes the last coin wins. (The last player to move wins. If you can't move, you lose.) 

Figure 1

Note: For n > 3, we use c1, c2, ..., cn to denote the coins clockwise and if Alice remove c2, then c1 and c3 are NOT adjacent! (Because there is an empty place between c1 and c3.) 

Suppose that both Alice and Bob do their best in the game. 
You are to write a program to determine who will finally win the game.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (1 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input. 

Output

For each test case, if Alice win the game,output "Alice", otherwise output "Bob". 

Sample Input

1
2
3
0

Sample Output

Alice
Alice
Bob

题意:给出n个硬币围成一圈,两个人轮流操作,每次操作可以移走一个或者两个相邻硬币,取走最后硬币的人获胜,求赢家。

分析:1、2个先手赢,3个后手赢,现在分析n>=4的情况,先手操作后,环就变成了链,如果取走链的中间一个或者两个,变成两个相同的链,那么接下来对方怎么取,就再另一串链进行相同操作,这样就可以赢了。

也就是说00 00、000 000、0000 0000、......这样的左右相同的情况都是先手必败的情况。

所以一条链时是先手必赢,一个环(n>3)是先手必败的情况。

#include<stdio.h>
int main(){
    int n;
    while(scanf("%d",&n)&&n!=0){
        if(n<3)printf("Alice\n");
        else printf("Bob\n");
    }
    return 0;
}

 

  

posted @ 2016-02-06 00:41  水郁  阅读(523)  评论(0编辑  收藏  举报
……