Problem Description

Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form
seed(x+1) = [seed(x) + STEP] % MOD
where '%' is the modulus operator.
Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.
For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.
If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.
Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

Input

Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).

Output

For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.

Sample Input

3 5 15 20 63923 99999

Sample Output

3 5 Good Choice 15 20 Bad Choice 63923 99999 Good Choice

 

Chris版:

基本思路:大致就是循环计算step的值,并记录每个值出现的次数,任何数只要循环计算mod+次肯定会出重复的值,所以只要计算mod-1次,然后判断期间有没有值是重复的就可以了。。。

代码如下:

#include<iostream>
#include<string>
#include<iomanip>
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
int p[100000];
int main()
{
	int i,a;
	int step,mod;
	bool lock;

	while(cin>>step>>mod)
	{
		i=0;
		memset(p,0,sizeof(p));
		p[0]=1;
		lock=true;
		a=0;
		for(i=1;i<mod;i++)
		{
			a=(a+step)%mod;
			p[a]++;
			if(p[a]>=2)
			{
				lock=false;
				break;
			}
		}
		cout<<setw(10)<<step<<setw(10)<<mod;
		if(lock==true)
			cout<<"    "<<"Good Choice\n"<<endl;
		else
			cout<<"    "<<"Bad Choice\n"<<endl;
	}
	return 0;
}
 
 
 
 
SEG:
#include<iostream>
#include<string>
#include<iomanip>
using namespace std;

int p[100000];

bool allOnes(int mod){
	for(int i=0;i<mod;i++)
		if(p[i]==0 || p[i]>1)
			return false;
	return true;
}

int main()
{
	int step,mod;
	while(cin>>step>>mod)
	{

		memset(p,0,sizeof(p));
		for(int i=0;p[0]==0||i!=0;i=(i+step)%mod)
			p[i]++;
		cout<<setiosflags(ios::right)<<setw(10)<<step;
		cout<<setiosflags(ios::right)<<setw(10)<<mod;
		if(allOnes(mod))
			cout<<setw(4)<<""<<"Good Choice\n"<<endl;
		else
			cout<<setw(4)<<""<<"Bad Choice\n"<<endl;
	}
	return 0;
}

 

 

SEG版:基本思路:就是先一直遍历计算step值,在出现重复的值时就推出循环,然后调用allOnes函数来判断下这mod个值出现的次数是否都是1,如果不是就是bad。。。。

这道题看似挺简单的,但是做的过程中也犯了好多很低级的错误,格式的输出比较需要注意的,总之,做水题讲究的不是技术,而是心态,千万不能因为简单而眼高手低了。。。。。。唉