3.Kali 1.0 / 2.0 安装中文输入法(谷歌pinyin + 其他)

搜狗输入法安装可以参考这个:http://www.cnblogs.com/dunitian/p/6662374.html

1.kali默认是没有中午输入法的,需要自己安装一下

2.首先我们先获取root权限

dnt@HackerKali:~$ su
密码:

3.安装中文输入法(apt-get 指令不会的同学可以学习一下基础指令哦)

root@HackerKali:/home/dnt# apt-get install fcitx

4.安装谷歌输入法

root@HackerKali:/home/dnt# apt-get install fcitx-googlepinyin

5.安装完成后没有什么变化,重启一下

root@HackerKali:/home/dnt# reboot

6.开机后就可以按住 ctrl 来回切换了(kali 2.0是按 ctrl+空格)

ctrl + 空格 切换

 

-----------------------------------------------------------------------------------

apt-get install fcitx-table-wbpy ttf-wqy-microhei ttf-wqy-zenhei  #拼音五笔
apt-get install ibus ibus-pinyin                    #经典的ibus
apt-get install fcitx fcitx-googlepinyin                 #fcitx拼音

-----------------------------------------------------------------------------------

注意:如果出现以下情况,请先输入 apt-get update 然后再进行上面的步骤

 

所有信息:

dnt@HackerKali:~$ su
密码:
root@HackerKali:/home/dnt# apt-get install fcitx
root@HackerKali:/home/dnt# apt-get install fcitx-googlepinyin
root@HackerKali:/home/dnt# reboot

dnt@HackerKali:~$ su
密码:
root@HackerKali:/home/dnt# apt-get install fcitx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
将会安装下列额外的软件包:
dialog fcitx-bin fcitx-config-common fcitx-config-gtk fcitx-data
fcitx-frontend-all fcitx-frontend-gtk2 fcitx-frontend-gtk3
fcitx-frontend-qt4 fcitx-libs fcitx-module-dbus fcitx-module-kimpanel
fcitx-module-lua fcitx-module-x11 fcitx-modules fcitx-ui-classic im-config
libopencc1 libpresage-data libpresage1 libtinyxml2.6.2 presage
建议安装的软件包:
fcitx-tools fcitx-m17n kdebase-bin plasma-widgets-addons
下列【新】软件包将被安装:
dialog fcitx fcitx-bin fcitx-config-common fcitx-config-gtk fcitx-data
fcitx-frontend-all fcitx-frontend-gtk2 fcitx-frontend-gtk3
fcitx-frontend-qt4 fcitx-libs fcitx-module-dbus fcitx-module-kimpanel
fcitx-module-lua fcitx-module-x11 fcitx-modules fcitx-ui-classic im-config
libopencc1 libpresage-data libpresage1 libtinyxml2.6.2 presage
升级了 0 个软件包,新安装了 23 个软件包,要卸载 0 个软件包,有 165 个软件包未被升级。
需要下载 8,171 kB 的软件包。
解压缩后会消耗掉 26.0 MB 的额外空间。
您希望继续执行吗?[Y/n]y
获取:1 http://http.kali.org/kali/ moto/main fcitx-libs amd64 1:4.2.4.1-7 [125 kB]
获取:2 http://http.kali.org/kali/ moto/main libopencc1 amd64 0.3.0-3 [891 kB]
获取:3 http://http.kali.org/kali/ moto/main dialog amd64 1.1-20120215-2 [324 kB]
获取:4 http://http.kali.org/kali/ moto/main fcitx-bin amd64 1:4.2.4.1-7 [31.7 kB]
获取:5 http://http.kali.org/kali/ moto/main fcitx-data all 1:4.2.4.1-7 [135 kB]
获取:6 http://http.kali.org/kali/ moto/main libtinyxml2.6.2 amd64 2.6.2-1 [43.8 kB]
获取:7 http://http.kali.org/kali/ moto/main libpresage-data all 0.8.8-1 [5,497 kB]
获取:8 http://http.kali.org/kali/ moto/main libpresage1 amd64 0.8.8-1 [211 kB]
获取:9 http://http.kali.org/kali/ moto/main fcitx-modules amd64 1:4.2.4.1-7 [159 kB]
获取:10 http://http.kali.org/kali/ moto/main fcitx all 1:4.2.4.1-7 [24.9 kB]
获取:11 http://http.kali.org/kali/ moto/main fcitx-config-common all 0.4.4-1 [3,988 B]
获取:12 http://http.kali.org/kali/ moto/main fcitx-config-gtk amd64 0.4.4-1 [37.0 kB]
获取:13 http://http.kali.org/kali/ moto/main fcitx-frontend-all all 1:4.2.4.1-7 [23.3 kB]
获取:14 http://http.kali.org/kali/ moto/main fcitx-module-dbus amd64 1:4.2.4.1-7 [39.5 kB]
获取:15 http://http.kali.org/kali/ moto/main fcitx-frontend-gtk2 amd64 1:4.2.4.1-7 [34.8 kB]
获取:16 http://http.kali.org/kali/ moto/main fcitx-frontend-gtk3 amd64 1:4.2.4.1-7 [34.9 kB]
获取:17 http://http.kali.org/kali/ moto/main fcitx-frontend-qt4 amd64 1:4.2.4.1-7 [82.7 kB]
获取:18 http://http.kali.org/kali/ moto/main fcitx-module-kimpanel amd64 1:4.2.4.1-7 [36.9 kB]
获取:19 http://http.kali.org/kali/ moto/main fcitx-module-lua amd64 1:4.2.4.1-7 [38.7 kB]
获取:20 http://http.kali.org/kali/ moto/main fcitx-module-x11 amd64 1:4.2.4.1-7 [109 kB]
获取:21 http://http.kali.org/kali/ moto/main fcitx-ui-classic amd64 1:4.2.4.1-7 [131 kB]
获取:22 http://http.kali.org/kali/ moto/main im-config all 0.21 [36.6 kB]
获取:23 http://http.kali.org/kali/ moto/main presage amd64 0.8.8-1 [121 kB]
下载 8,171 kB,耗时 18秒 (452 kB/s)
Selecting previously unselected package fcitx-libs:amd64.
(正在读取数据库 ... 系统当前共安装有 320462 个文件和目录。)
正在解压缩 fcitx-libs:amd64 (从 .../fcitx-libs_1%3a4.2.4.1-7_amd64.deb) ...
Selecting previously unselected package libopencc1:amd64.
正在解压缩 libopencc1:amd64 (从 .../libopencc1_0.3.0-3_amd64.deb) ...
Selecting previously unselected package dialog.
正在解压缩 dialog (从 .../dialog_1.1-20120215-2_amd64.deb) ...
Selecting previously unselected package fcitx-bin.
正在解压缩 fcitx-bin (从 .../fcitx-bin_1%3a4.2.4.1-7_amd64.deb) ...
Selecting previously unselected package fcitx-data.
正在解压缩 fcitx-data (从 .../fcitx-data_1%3a4.2.4.1-7_all.deb) ...
Selecting previously unselected package libtinyxml2.6.2.
正在解压缩 libtinyxml2.6.2 (从 .../libtinyxml2.6.2_2.6.2-1_amd64.deb) ...
Selecting previously unselected package libpresage-data.
正在解压缩 libpresage-data (从 .../libpresage-data_0.8.8-1_all.deb) ...
Selecting previously unselected package libpresage1.
正在解压缩 libpresage1 (从 .../libpresage1_0.8.8-1_amd64.deb) ...
Selecting previously unselected package fcitx-modules.
正在解压缩 fcitx-modules (从 .../fcitx-modules_1%3a4.2.4.1-7_amd64.deb) ...
Selecting previously unselected package fcitx.
正在解压缩 fcitx (从 .../fcitx_1%3a4.2.4.1-7_all.deb) ...
Selecting previously unselected package fcitx-config-common.
正在解压缩 fcitx-config-common (从 .../fcitx-config-common_0.4.4-1_all.deb) ...
Selecting previously unselected package fcitx-config-gtk.
正在解压缩 fcitx-config-gtk (从 .../fcitx-config-gtk_0.4.4-1_amd64.deb) ...
Selecting previously unselected package fcitx-frontend-all.
正在解压缩 fcitx-frontend-all (从 .../fcitx-frontend-all_1%3a4.2.4.1-7_all.deb) ...
Selecting previously unselected package fcitx-module-dbus.
正在解压缩 fcitx-module-dbus (从 .../fcitx-module-dbus_1%3a4.2.4.1-7_amd64.deb) ...
Selecting previously unselected package fcitx-frontend-gtk2:amd64.
正在解压缩 fcitx-frontend-gtk2:amd64 (从 .../fcitx-frontend-gtk2_1%3a4.2.4.1-7_amd64.deb) ...
Selecting previously unselected package fcitx-frontend-gtk3:amd64.
正在解压缩 fcitx-frontend-gtk3:amd64 (从 .../fcitx-frontend-gtk3_1%3a4.2.4.1-7_amd64.deb) ...
Selecting previously unselected package fcitx-frontend-qt4:amd64.
正在解压缩 fcitx-frontend-qt4:amd64 (从 .../fcitx-frontend-qt4_1%3a4.2.4.1-7_amd64.deb) ...
Selecting previously unselected package fcitx-module-kimpanel.
正在解压缩 fcitx-module-kimpanel (从 .../fcitx-module-kimpanel_1%3a4.2.4.1-7_amd64.deb) ...
Selecting previously unselected package fcitx-module-lua.
正在解压缩 fcitx-module-lua (从 .../fcitx-module-lua_1%3a4.2.4.1-7_amd64.deb) ...
Selecting previously unselected package fcitx-module-x11.
正在解压缩 fcitx-module-x11 (从 .../fcitx-module-x11_1%3a4.2.4.1-7_amd64.deb) ...
Selecting previously unselected package fcitx-ui-classic.
正在解压缩 fcitx-ui-classic (从 .../fcitx-ui-classic_1%3a4.2.4.1-7_amd64.deb) ...
Selecting previously unselected package im-config.
正在解压缩 im-config (从 .../im-config_0.21_all.deb) ...
Selecting previously unselected package presage.
正在解压缩 presage (从 .../presage_0.8.8-1_amd64.deb) ...
正在处理用于 man-db 的触发器...
正在处理用于 shared-mime-info 的触发器...
正在处理用于 desktop-file-utils 的触发器...
正在处理用于 gnome-menus 的触发器...
正在处理用于 hicolor-icon-theme 的触发器...
正在处理用于 gnome-icon-theme 的触发器...
正在处理用于 libgtk2.0-0:amd64 的触发器...
正在处理用于 libgtk-3-0:amd64 的触发器...
正在处理用于 menu 的触发器...
正在设置 fcitx-libs:amd64 (1:4.2.4.1-7) ...
正在设置 libopencc1:amd64 (0.3.0-3) ...
正在设置 dialog (1.1-20120215-2) ...
正在设置 fcitx-bin (1:4.2.4.1-7) ...
正在设置 fcitx-data (1:4.2.4.1-7) ...
正在设置 libtinyxml2.6.2 (2.6.2-1) ...
正在设置 libpresage-data (0.8.8-1) ...
正在设置 libpresage1 (0.8.8-1) ...
正在设置 fcitx-modules (1:4.2.4.1-7) ...
正在设置 fcitx (1:4.2.4.1-7) ...
update-alternatives: using /etc/X11/xinit/xinput.d/fcitx to provide /etc/X11/xinit/xinput.d/ja_JP (xinput-ja_JP) in 自动模式
update-alternatives: using /etc/X11/xinit/xinput.d/fcitx to provide /etc/X11/xinit/xinput.d/ko_KR (xinput-ko_KR) in 自动模式
update-alternatives: using /etc/X11/xinit/xinput.d/fcitx to provide /etc/X11/xinit/xinput.d/zh_CN (xinput-zh_CN) in 自动模式
update-alternatives: using /etc/X11/xinit/xinput.d/fcitx to provide /etc/X11/xinit/xinput.d/zh_TW (xinput-zh_TW) in 自动模式
update-alternatives: using /etc/X11/xinit/xinput.d/fcitx to provide /etc/X11/xinit/xinput.d/zh_HK (xinput-zh_HK) in 自动模式
update-alternatives: using /etc/X11/xinit/xinput.d/fcitx to provide /etc/X11/xinit/xinput.d/zh_SG (xinput-zh_SG) in 自动模式
正在设置 fcitx-config-common (0.4.4-1) ...
正在设置 fcitx-config-gtk (0.4.4-1) ...
正在设置 fcitx-frontend-all (1:4.2.4.1-7) ...
正在设置 fcitx-module-dbus (1:4.2.4.1-7) ...
正在设置 fcitx-frontend-gtk2:amd64 (1:4.2.4.1-7) ...
正在设置 fcitx-frontend-gtk3:amd64 (1:4.2.4.1-7) ...
正在设置 fcitx-frontend-qt4:amd64 (1:4.2.4.1-7) ...
正在设置 fcitx-module-kimpanel (1:4.2.4.1-7) ...
正在设置 fcitx-module-lua (1:4.2.4.1-7) ...
正在设置 fcitx-module-x11 (1:4.2.4.1-7) ...
正在设置 fcitx-ui-classic (1:4.2.4.1-7) ...
正在设置 im-config (0.21) ...
正在设置 presage (0.8.8-1) ...
正在处理用于 menu 的触发器...
root@HackerKali:/home/dnt# apt-get install fcitx-googlepinyin
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
将会安装下列额外的软件包:
libgooglepinyin0
下列【新】软件包将被安装:
fcitx-googlepinyin libgooglepinyin0
升级了 0 个软件包,新安装了 2 个软件包,要卸载 0 个软件包,有 165 个软件包未被升级。
需要下载 774 kB 的软件包。
解压缩后会消耗掉 1,256 kB 的额外空间。
您希望继续执行吗?[Y/n]y
获取:1 http://http.kali.org/kali/ moto/main libgooglepinyin0 amd64 0.1.2-1 [764 kB]
获取:2 http://http.kali.org/kali/ moto/main fcitx-googlepinyin amd64 0.1.5-2 [10.6 kB]
下载 774 kB,耗时 3秒 (236 kB/s)
Selecting previously unselected package libgooglepinyin0:amd64.
(正在读取数据库 ... 系统当前共安装有 321079 个文件和目录。)
正在解压缩 libgooglepinyin0:amd64 (从 .../libgooglepinyin0_0.1.2-1_amd64.deb) ...
Selecting previously unselected package fcitx-googlepinyin.
正在解压缩 fcitx-googlepinyin (从 .../fcitx-googlepinyin_0.1.5-2_amd64.deb) ...
正在设置 libgooglepinyin0:amd64 (0.1.2-1) ...
正在设置 fcitx-googlepinyin (0.1.5-2) ...
root@HackerKali:/home/dnt# reboot

posted @ 2015-08-08 00:18 毒逆天 阅读(...) 评论(...) 编辑 收藏
毒逆天