HDU 1011 Starship Troopers【树形DP】

Problem Description
You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.
To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.
A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a compute
Input
The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.
The last test case is followed by two -1's.
Output
For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.
Sample Input
5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1
Sample Output
50
7
题意: 给你一个树形山洞,n个房间,m个助手,入口是1,每个房间里面有一定数量的怪,每个手下可以干掉20个怪,
只要干掉该房间里面所有的怪才能得到该房间的经验值,问你如何分配手下能得到最大经验值。
分析: 树形DFS,定义f[i][j]表示以 i 节点为根的树分配 j 个手下得到的最大经验值。
View Code
#include<stdio.h>
#include<string.h>
#define max(a,b)(a)>(b)?(a):(b)
struct node
{
    int to,next;
}q[500];
int tot,n,m;
int head[102];
int v[102];
int b[102],w[102];
int dp[102][102];
void add(int s,int u)
{
    q[tot].to=u;
    q[tot].next=head[s];
    head[s]=tot++;
}
void dfs(int r)
{
    v[r]=1;
    int cost,i,j,k,son;
    cost=(b[r]+19)/20;
    for(i=cost;i<=m;i++)
        dp[r][i]=w[r];            // 小于最低数目的情况下 无法得到经验值 
    for(i=head[r];i;i=q[i].next)
    {
        son=q[i].to;
        if(!v[son])
        {    
            dfs(son);
            for(j=m;j>=cost;j--)      //  注意的地方!!
                for(k=1;j+k<=m;k++)
                    if(dp[son][k])
                        dp[r][j+k]=max(dp[r][j+k],dp[r][j]+dp[son][k]);
        }
    }
}
int main()
{
    int i,x,y;
    while(scanf("%d%d",&n,&m),n>=0||m>=0)
    {
        tot=1;
        memset(v,0,sizeof(v));
        memset(head,0,sizeof(head));
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++)
            scanf("%d%d",&b[i],&w[i]);
        for(i=1;i<n;i++)
        {
            scanf("%d%d",&x,&y);
            add(x,y);
            add(y,x);
        }
        if(!m)
        {
            printf("0\n");
            continue;
        }
        dfs(1);
        printf("%d\n",dp[1][m]);
    }
    return 0;
}

 


posted @ 2012-04-21 12:49  'wind  阅读(261)  评论(0编辑  收藏  举报