HLG 1338 Monkey CC

Description

Cc is a lovely monkey. It likes to play the game "catching plates".

The game is as follows.

There are n pegs in a line numbered from 1 to n. Cc stands on the first peg at the beginning. It is rather hard for Cc to jump from peg i to peg i+1(i+1<=n) or peg i-1(i-1>=1), which takes him exactly one second. He can jump at most t times. And he will only jump at the beginning of one second.There is a clown at the other end. He has m plates in hand. He will throw a plate to one peg every second. The clown will throw the plate exactly to the peg. The plates will get broken if they hit the pegs. Cc can catch the plate if only he stands on the peg the plate is thrown to. For simplicity, the process of throwing and catching don't take any time at all. Suppose the clown will throw a plate to the 9th peg at the 9th second, if Cc stands on peg 9 at the 8th second and stands still for a second, or if Cc stand on peg 8 at the 8th second and jumps to peg 9, or if Cc stand on peg 10 at the 8th second and jumps to peg 9, he can catch the plate.

There is a positive integer on each plate, indicating the bananas Cc can get if he catch that plate. Cc will know the way the clown throw the plates in advance. Now he wants to get as many bananas as possible.

Input

For each test case,the first line contains three integers n, m and t(1<=n<=100,1<=m<=100,0<=t<=100), indicating the number of the pegs, the number of the plates and the maximum number Cc can jump.The next m lines gives ai and bi each, which means the clown will throw a plate with number bi on it to peg ai at the ith second.

Process to the end of file.

Output
For each test case, first print a line saying "Scenario #k", where k is the number of the test case.Then, print the maximum number Cc can get, one per line.Print a blank line after each test case, even after the last one.
Sample Input

4 4 2

2 10

3 15

1 10

1 8

4 4 4

2 10

3 15

1 10

1 8

2 2 1

1 1

2 1

Sample Output

Scenario #1

28

Scenario #2

33

Scenario #3

2

思路:  猴子的每一个位置都可能有其他三种状态转移而来  f[x][i][j] =max(f[x+1][i-1][j+1],f[x+1][i+1][j+1],f[x+1][i][j])+c[t][i]

View Code
#include<stdio.h>
#include<string.h>
#define max(a,b)(a)>(b)?(a):(b)
int c[102][102];
int f[102][102][102];
int n,m,k;
int dfs(int x,int i,int j)
{
if(x>m) return 0;
if(f[x][i][j]!=-1) return f[x][i][j];
int tmp1=0,tmp2=0,tmp3=0;
if(i>1&&j<k)
tmp1=dfs(x+1,i-1,j+1);
if(i<n&&j<k)
tmp2=dfs(x+1,i+1,j+1);
tmp3=max(tmp1,tmp2);
tmp3=max(tmp3,dfs(x+1,i,j));
f[x][i][j]=tmp3+c[x][i];
return f[x][i][j];
}
int main()
{
int p,q,res,i,ca=1;
while(scanf("%d%d%d",&n,&m,&k)!=EOF)
{
memset(c,0,sizeof(c));
memset(f,-1,sizeof(f));
for(i=1;i<=m;i++)
{
scanf("%d%d",&p,&q);
c[i][p]=q;
}
int tmp1=dfs(1,1,0);
int tmp2=dfs(1,2,1);
res=max(tmp1,tmp2);
printf("Scenario #%d\n",ca++);
printf("%d\n\n",res);
}
return 0;
}



posted @ 2012-04-08 21:55  'wind  阅读(369)  评论(0编辑  收藏  举报