POJ 3254 Corn Fields【状态压缩DP】

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  
code:
View Code
#include<stdio.h>
#include<string.h>
#define mod 100000000
#define clr(x)memset(x,0,sizeof(x))
int co(int x)
{
if(x<2)
return 1;
if(x&1 && x&2)
return 0;
return co(x>>1);
}
int last[1<<12];
int state[12];
int next[1<<12];
int ss[1<<13];
int main()
{
int top=0,m,n,i,j,k,p,s,res;
while(scanf("%d%d",&m,&n)!=EOF)
{
for(i=0;i<m;i++)
{
state[i]=0;
for(j=0;j<n;j++)
{
scanf("%d",&p);
state[i]=(state[i]<<1)+1-p;
}
}
s=(1<<n)-1;
for(i=0;i<s;i++)
if(co(i)==1)
ss[i]=1;
else ss[i]=0;
for(i=0;i<s;i++)
{
if(ss[i]==0||i&state[0])
last[i]=0;
else last[i]=1;
}
for(i=1;i<m;i++)
{
for(j=0;j<s;j++)
{
next[j]=0;
if(ss[j]==0||j&state[i])
continue;
for(k=0;k<s;k++)
{
if(j&k) continue;
next[j]=(next[j]+last[k])%mod;
}
}
for(j=0;j<s;j++)
last[j]=next[j];
}
res=0;
for(i=0;i<s;i++)
res=(res+last[i])%mod;
printf("%d\n",res);
}
return 0;
}

posted @ 2012-03-30 21:51  'wind  阅读(343)  评论(0编辑  收藏  举报