(HDOJ 2044)一只小蜜蜂...

 

一只小蜜蜂...


Problem Description
有一只经过训练的蜜蜂只能爬向右侧相邻的蜂房,不能反向爬行。请编程计算蜜蜂从蜂房a爬到蜂房b的可能路线数。
其中,蜂房的结构如下所示。
 

Input
输入数据的第一行是一个整数N,表示测试实例的个数,然后是N 行数据,每行包含两个整数a和b(0<a<b<50)。
 

Output
对于每个测试实例,请输出蜜蜂从蜂房a爬到蜂房b的可能路线数,每个实例的输出占一行。
 

Sample Input
2

1 2 

3 6

 

Sample Output
1

3

 

Author
lcy
 

Source
 

 

 AC code:

#include <stdio.h>

int main(void)
{
    
int i, j, n;
    __int64 d[
51= {112,};

    
for (i = 3; i < 51; i++)
        d[i] 
= d[i-1+ d[i-2];
    scanf(
"%d"&n);
    
while (n-- && scanf("%d%d"&i, &j) != EOF)
        printf(
"%I64d\n", i > j ? 0 : d[j-i]);

    
return 0;
}

             

posted @ 2011-04-24 23:12  cpoint  阅读(729)  评论(0编辑  收藏  举报
浏览次数:travelocity promotion codes