HDU 1159 Common Subsequence (LCS)

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24972    Accepted Submission(s): 11071


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

 

Sample Input
abcfbc abfcab programming contest abcd mnp
 

 

Sample Output
4 2 0
 

 

Source
 

 

Recommend
Ignatius
 
这是一道LCS的裸题:求两个字符串的最长的公共子序列
那么可以定义状态:dp[i][j]以a字符串的第i个字符结尾并且以b字符串的第j个字符结尾的最长公共子序列的长度
状态转移:
if(a[i]==b[j]),dp[i][j]=dp[i-1][j-1]+1; //当两个字符串的中的某一个字符相同时,状态由当前字符串前一位的状态转移过来
else dp[i][j]=max(dp[i-1][j],dp[i][j-1])
最后要注意边界以及初始化的问题
dp[i][0]=0;
dp[0][j]=0;
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<stdlib.h>
#include<queue>
#include<stack>
#include<algorithm>
#define LL __int64
using namespace std;
const int MAXN=1000+5;
const int INF=0x3f3f3f3f;
const double EPS=1e-9;
int dir4[][2]={{0,1},{1,0},{0,-1},{-1,0}};
int dir8[][2]={{0,1},{1,1},{1,0},{1,-1},{0,-1},{-1,-1},{-1,0},{-1,1}};
int dir_8[][2]={{-2,1},{-1,2},{1,2},{2,1},{2,-1},{1,-2},{-1,-2},{-2,-1}};
int dp[1000][1000];
char a[1000],b[1000];
int main()
{
    while(scanf("%s %s",a+1,b+1)!=EOF)
    {
        int lena=strlen(a+1),lenb=strlen(b+1);
        int i,j;
        memset(dp,0,sizeof(dp));
        for(i=0;i<=lena;i++)
            dp[i][0]=0;
        for(j=0;j<=lenb;j++)
            dp[0][j]=0;
        for(i=1;i<=lena;i++)
        {
            for(j=1;j<=lenb;j++)
            {
                if(a[i]==b[j])
                    dp[i][j]=dp[i-1][j-1]+1;
                else
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
            }
        }
        printf("%d\n",dp[lena][lenb]);
    }
    return 0;
}
View Code

 

posted @ 2015-01-26 16:57  Cliff Chen  阅读(137)  评论(0编辑  收藏  举报