Hyperledger Fabric 1.0 从零开始(二)——环境构建(公网)

1:环境构建

在本文中用到的宿主机环境是Centos ,版本为Centos.x86_647.2,通过Docker 容器来运行Fabric的节点,版本为v1.0。因此,启动Fabric网络中的节点需要先安装Docker、Docker-compose和Go语言环境,然后在网上拉取相关的Docker镜像,再通过配置compose文件来启动各个节点。

 

1.1Docker安装

进入docker官网

GetDocker -》Centos -》Get CE(社区版)-》Get Docker CE on CentOS -》Install Docker CE on CentOS。

按照官网给出的步骤安装Docker CE版

如果在服务器上有旧版的docker,需要先执行卸载操作,如下:.

$ sudo yum remove docker \ 
                               docker-common \ 
                               docker-selinux \ 
                               docker-engine

 

随后开始安装Docker CE

 1 $ sudo yum install -y yum-utils device-mapper-persistent-data lvm2
 2 
 3 $ sudo yum-config-manager \
 4     --add-repo \
 5 https://download.docker.com/linux/centos/docker-ce.repo
 6 
 7 $ sudo yum-config-manager --enable docker-ce-edge
 8 
 9 $ sudo yum-config-manager --enable docker-ce-test
10 
11 $ sudo yum-config-manager --disable docker-ce-edge
12 
13 $ sudo yum makecache fast
14 
15 $ sudo yum install docker-ce

执行查询docker版本号,看是否安装成功

docker --version

 

正常情况下会出现如下视图

docker启动:

service docker start

docker开机自启动:

chkconfig docker on

 

 

1.2Docker-Compose安装

Docker-Compose安装可参照官网步骤进行,需要服务器支持curl功能,如果服务器不支持curl,需要执行如下操作安装curl依赖:

yum install curl

根据官网所指向github项目,目前docker-compose最新版为1.15.0

执行如下操作下载docker-compose

curl -L https://github.com/docker/compose/releases/download/1.15.0/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-composechmod +x /usr/local/bin/docker-compose

该下载目录为/usr/local/bin/docker-compose,且权限已经给出,再执行docker-compose --version检查版本号,或许会有如下示:

如果出现上述提示,执行以下操作

cp /usr/local/bin/docker-compose /usr/bin

docker-compose拷贝至/usr/bin目录下,再次执行

docker-compose --version

正常情况下会打印docker-compose的版本信息,如下视图

 

docker常用命令如下:

杀死所有正在运行的容器

docker kill $(docker ps -a -q)

删除所有已经停止的容器

docker rm $(docker ps -a -q)

删除所有镜像

docker rmi $(docker images -q)

强制删除所有镜像

docker rmi -f $(docker images -q)

 

 

1.3Go语言安装

1、参照Go官网,找到linux版本下载路径,执行以下操作下载最新版Go语言包

 

curl -O https://storage.googleapis.com/golang/go1.8.3.linux-amd64.tar.gz

 

或直接通过https://golang.org/doc/install?download=go1.8.3.linux-amd64.tar.gz链接下载最新版。切记,该URL中版本号甚至链接本身以官网为主!

2、解压go1.8.3.linux-amd64.tar.gz至/usr/local目录下,执行如下操作:

 

tar -C /usr/local -xzf go1.8.3.linux-amd64.tar.gz

3、配置go环境变量

修改/etc/profile文件使其永久性生效,并对所有系统用户生效,在文件末尾加上如下两行代码

1 export PATH=$PATH:/usr/local/go/bin
2 export GOPATH=/opt/gopath

上述修改/etc/profile文件具体实现如下操作:

1 cd /etc
2 vim profile

 

执行修改后,继续执行:

source profile

 

使其修改生效。随后可通过下述命令:

echo $PATH

查看是否添加成功。

最后可通过

 

go version

 

查看当前go版本信息,正常情况下如下视图:

 

 

 

至此整个Fabric所需的基础环境都已经搭建起来了,这种搭建方式是有网络的情况下成立的,很多公司都有自己的内网,或者是禁制本地服务器连接外部网络,又或者是连接外部网络的时候需要申请各种权限,导致无法实现本篇所说的安装过程,故此,下一章Hyperledger Fabric 1.0 从零开始(三)——内网(准离线)环境构建将会就此来讲述一下如何在离线环境下实现Fabric环境的搭建过程。

 

posted @ 2017-09-16 14:13 Aberic 阅读(...) 评论(...) 编辑 收藏