POJ 2263 Heavy Cargo(Floyd + map)

Heavy Cargo
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3768   Accepted: 2013

Description

Big Johnsson Trucks Inc. is a company specialized in manufacturing big trucks. Their latest model, the Godzilla V12, is so big that the amount of cargo you can transport with it is never limited by the truck itself. It is only limited by the weight restrictions that apply for the roads along the path you want to drive.

Given start and destination city, your job is to determine the maximum load of the Godzilla V12 so that there still exists a path between the two specified cities.

Input

The input will contain one or more test cases. The first line of each test case will contain two integers: the number of cities n (2<=n<=200) and the number of road segments r (1<=r<=19900) making up the street network.
Then r lines will follow, each one describing one road segment by naming the two cities connected by the segment and giving the weight limit for trucks that use this segment. Names are not longer than 30 characters and do not contain white-space characters. Weight limits are integers in the range 0 - 10000. Roads can always be travelled in both directions.
The last line of the test case contains two city names: start and destination.
Input will be terminated by two values of 0 for n and r.

Output

For each test case, print three lines:
  • a line saying "Scenario #x" where x is the number of the test case
  • a line saying "y tons" where y is the maximum possible load
  • a blank line

Sample Input

4 3
Karlsruhe Stuttgart 100
Stuttgart Ulm 80
Ulm Muenchen 120
Karlsruhe Muenchen
5 5
Karlsruhe Stuttgart 100
Stuttgart Ulm 80
Ulm Muenchen 120
Karlsruhe Hamburg 220
Hamburg Muenchen 170
Muenchen Karlsruhe
0 0

Sample Output

Scenario #1
80 tons
 
Scenario #2
170 tons

Source

题意:求各城市每条给定起点和终点间通路的最小负载,并据此求出所有最小负载中的最大值.
思路:题目给的是城市名用map.
收获:map用法 + Floyd
#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <string>
#include <cstring>
#include <stack>
#include <queue>
#include <list>
#include <vector>
#include <map>
#include <set>
using namespace std;

const int INF=0x3f3f3f3f;
const double eps=1e-10;
const double PI=acos(-1.0);
#define maxn 500

map<string, int> a;
char s1[32];
char s2[32];
int  c[maxn][maxn];
int v[maxn][maxn];
int pre[maxn][maxn];
int main()
{
    int n, m, w;
    int cas = 0;
    while(~scanf("%d%d",&n,&m)&&(n+m))
    {
        int cnt = 0;
        memset(c, 0, sizeof c);
        for(int i = 0; i < m; i++)
        {
            scanf("%s%s%d", s1, s2, &w);
            if(!a.count(s1))
            a[s1] = cnt++;
            if(!a.count(s2))
            a[s2] = cnt++;
            c[a[s1]][a[s2]] = c[a[s2]][a[s1]] = w;
        }
//    map<string, int>::iterator it;
//    for(it=a.begin();it!=a.end();++it)
//        cout<<"key: "<<it->first <<" value: "<<it->second<<endl;
        for(int i = 0; i < n; i++)
            for(int j = 0; j < n; j++)
            {
                v[i][j] = c[i][j];
                //pre[i][j] = i;
            }

        for(int k = 0; k < n; k++)
            for(int i = 0; i<n; i++)
                for(int j = 0; j < n; j++)
                {
                    v[i][j] = max(v[i][j], min(v[i][k],v[k][j]));
                   //pre[i][j] = pre[k][j];
                }

        scanf("%s%s",s1,s2);

        printf("Scenario #%d\n", ++cas);
        printf("%d tons\n",v[a[s1]][a[s2]]);
        puts("");
    }
    return 0;
}

 

posted @ 2015-08-09 11:18  JoneZP  阅读(550)  评论(0编辑  收藏  举报