[POJ](1740)A New Stone Game --找规律博弈(博弈)

A New Stone Game
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 6049   Accepted: 3307

Description

Alice and Bob decide to play a new stone game.At the beginning of the game they pick n(1<=n<=10) piles of stones in a line. Alice and Bob move the stones in turn. 
At each step of the game,the player choose a pile,remove at least one stones,then freely move stones from this pile to any other pile that still has stones. 
For example:n=4 and the piles have (3,1,4,2) stones.If the player chose the first pile and remove one.Then it can reach the follow states. 
2 1 4 2 
1 2 4 2(move one stone to Pile 2) 
1 1 5 2(move one stone to Pile 3) 
1 1 4 3(move one stone to Pile 4) 
0 2 5 2(move one stone to Pile 2 and another one to Pile 3) 
0 2 4 3(move one stone to Pile 2 and another one to Pile 4) 
0 1 5 3(move one stone to Pile 3 and another one to Pile 4) 
0 3 4 2(move two stones to Pile 2) 
0 1 6 2(move two stones to Pile 3) 
0 1 4 4(move two stones to Pile 4) 
Alice always moves first. Suppose that both Alice and Bob do their best in the game. 
You are to write a program to determine who will finally win the game. 

Input

The input contains several test cases. The first line of each test case contains an integer number n, denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game, you may assume the number of stones in each pile will not exceed 100. 
The last test case is followed by one zero. 

Output

For each test case, if Alice win the game,output 1,otherwise output 0. 

Sample Input

3
2 1 3
2
1 1
0

Sample Output

1
0

Source


解题新知:这类博弈题目找到必胜态是关键,做的还是太少,思考得太少……

参考:http://blog.csdn.net/liuqiyao_01/article/details/8857312

AC代码:
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    int n;
    while(cin>>n && n)
    {
        int stone[15];
        int sum[105];
        memset(sum,0,sizeof(sum));
        for(int i=0;i<n;i++)
        {
            cin>>stone[i];
            sum[stone[i]]++;
        }
        int num=0;
        sort(stone,stone+n);
        for(int i=0;i<100;i++)
        {
            if(sum[i]%2==1)
                num++;
        }
        if(num)
            cout<<"1"<<endl;
        else
            cout<<"0"<<endl;
    }
    return 0;
}


posted @ 2017-08-18 09:58  WangMeow  阅读(222)  评论(0编辑  收藏  举报