[SDUT](2073)活动选择问题 ---贪心

活动选择问题

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

 sdut 大学生艺术中心每天都有n个活动申请举办,但是为了举办更多的活动,必须要放弃一些活动,求出每天最多能举办多少活动。

Input

 输入包括多组输入,每组输入第一行为申请的活动数n(n<100),从第2行到n+1行,每行两个数,是每个活动的开始时间b,结束时间e;

Output

 输出每天最多能举办的活动数。

Example Input

12
15 20
15 19
8 18
10 15
4 14
6 12
5 10
2 9
3 8
0 7
3 4
1 3

Example Output

5

解题新知:其实就是暑假不AC,练练sort函数~\(≧▽≦)/~


AC代码:
#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
    int s;
    int e;
};
bool cmp(node a,node b)
{
    return a.e<b.e;
}
int main()
{
    int n;
    node time[105];
    while(cin>>n)
    {
        for(int i=0;i<n;i++)
        {
            cin>>time[i].s>>time[i].e;
        }
        sort(time,time+n,cmp);
        int sum=1;
        int End=time[0].e;
        for(int i=1;i<n;i++)
        {
            if(time[i].s>=End)
            {
                End=time[i].e;
                sum++;
            }
        }
        cout<<sum<<endl;
    }
    return 0;
}


posted @ 2017-08-31 16:33  WangMeow  阅读(275)  评论(0编辑  收藏  举报