[SDUT](2117)数据结构实验之链表二:逆序建立链表 ---链式存储(线性表)

数据结构实验之链表二:逆序建立链表

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。

Input

第一行输入整数N;;
第二行依次输入N个整数,逆序建立单链表。

Output

依次输出单链表所存放的数据。

Example Input

10
11 3 5 27 9 12 43 16 84 22 

Example Output

22 84 16 43 12 9 27 5 3 11 

Hint

不能使用数组!

AC代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
using namespace std;
typedef struct Node
{
    int data;
    struct Node *next;
}node;
void creatLinklist(node * &L,int n)
{
    node *s;
    L = (node *)malloc(sizeof(node));
    L->next = NULL;
    int d;
    for(int i=0;i<n;i++)//头插法
    {
        scanf("%d",&d);
        s = (node *)malloc(sizeof(node));
        s->data = d;
        s->next = L->next;
        L->next = s;
    }
}
void print(node *L)
{
    node *p = L->next;
    while(p!=NULL)
    {
        if(p->next!=NULL)
            printf("%d ",p->data);
        else
            printf("%d\n",p->data);
        p = p->next;
    }
}
int main()
{
    int n;
    node *L;
    scanf("%d",&n);
    creatLinklist(L,n);
    print(L);
    return 0;
}


posted @ 2017-09-08 15:26  WangMeow  阅读(337)  评论(0编辑  收藏  举报