[SDUT](2112 && 1139)数据结构实验之链表七:单链表中重复元素的删除 ---链表操作(线性表)

数据结构实验之链表七:单链表中重复元素的删除

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

Input

第一行输入元素个数 n (1 <= n <= 15);
第二行输入 n 个整数,保证在 int 范围内。

Output

第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

Example Input

10
21 30 14 55 32 63 11 30 55 30

Example Output

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

Hint


AC代码:
#include<iostream>
#include<cstdio>
#include<cstdlib>
using namespace std;
typedef struct Node
{
    int length;
    int data;
    struct Node *next;
}node;
void creatLinklist(node * &L,int n)
{
    int d;
    node *s;
    L = (node *)malloc(sizeof(node));
    L->next = NULL;
    L->length = n;
    for(int i=0;i<n;i++)
    {
        s = (node *)malloc(sizeof(node));
        scanf("%d",&d);
        s->data = d;
        s->next = L->next;
        L->next = s;
    }
}
void print(node *L)
{
    node *p = L->next;
    printf("%d\n",L->length);
    while(p!=NULL)
    {
        if(p->next!=NULL)
            printf("%d ",p->data);
        else
            printf("%d\n",p->data);
        p = p->next;
    }
}
void LinklistDelete(node * &L)
{
    node *p = L->next;
    node *q;
    node *now;
    while(p!=NULL)
    {
        now = p;
        q = p->next;
        while(q!=NULL)
        {
            if(p->data == q->data)
            {
                now->next = q->next;
                q = now->next;
                L->length--;
            }
            else
            {
                now = now->next;
                q = q->next;
            }
        }
        p = p->next;
    }
}
int main()
{
    int n;
    node *L;
    scanf("%d",&n);
    creatLinklist(L,n);
    print(L);
    LinklistDelete(L);
    print(L);
    return 0;
}


posted @ 2017-09-09 10:42  WangMeow  阅读(188)  评论(0编辑  收藏  举报