HDU 2594 Simpsons’ Hidden Talents(KMP)

 

 

          Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 953    Accepted Submission(s): 328


Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 

 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 

 

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 

 

Sample Input
clinton
homer
riemann
marjorie
 

 

Sample Output
0
rie 3
 

 

Source
 

 

Recommend
lcy
 
 
题意:给定两个字符串s1,s2,求最长的s1前缀ss使得ss为s2的最长后缀,输出该字符串和其长度。
 
解法一:KMP
 
#include<iostream>
using namespace std;
#define Size 50002
char s1[Size],s2[Size];
int next[Size];
int len1,len2;
void get_next()
{
    int i,j;
    i=0;
    j=-1;
    next[0]=-1;
    while(i<len1)
    {
        if(j==-1||s1[i]==s1[j])
        {
            i++;
            j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
}
void kmp()
{
    int i,j;
    i=0;
    j=0;
    while(i<len2)
    {
        if(j==-1||s1[j]==s2[i])
        {
            i++; 
            j++;
        }
        else  
            j=next[j];
    }
    if(!j) // 匹配不了
        printf("%d\n",j);
    else 
    {
        for(int k=0;k<j;k++) // 在s1中前j个字符就是共同最长的
            printf("%c",s1[k]);
        printf(" %d\n",j);
    }
}
int main()
{
    while(scanf("%s %s",s1,s2)!=EOF) // 题目要求最长的s1的前缀同时满足是s2的后缀
    {
       len1=strlen(s1); // 可以反过来想一下,把s2作为主串,s1为子串
        len2=strlen(s2); // 然后s1不断往后移动,匹配之后就可以了
        get_next();
       kmp();
    }
    return 0;
}

 

 

解法二:

利用前缀后缀特性,把两个字符串接起来,求前缀后缀子串,注意其终止条件的变化,这里前缀后缀子串的长度必须小于s1,s2长度的最小值。

 

posted @ 2012-09-13 22:00  Suhx  阅读(1683)  评论(2编辑  收藏  举报