HDU 2069

Coin Change

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7505    Accepted Submission(s): 2489


Problem Description

 

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
 

 

Input

 

The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
 

 

Output

 

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
 

 

Sample Input
11
26
 

 

Sample Output
4
13
 
看完题目就本能性地用了母函数,敲好试了下数据 对的 很开心submit了 结果WA 再看一遍题目 猛然间惊醒……
Your program should be able to handle up to 100 coins.
然后就不知道怎么处理了……
 
 
后来百度了 发现有直接暴力过的…… 无语
 
View Code
#include<stdio.h>
#include<string.h>

int main()
{
    int n,i,j,k,m,cent,a[6]={1,5,10,25,50},c[252];
     memset(c,0,sizeof(c));
    for(i=0;i<101&&a[0]<251;i++)
        for(j=0;i+j<101&&a[0]*i+a[1]*j<251;j++)
            for(k=0;i+j+k<101&&a[0]*i+a[1]*j+a[2]*k<251;k++)
                for(m=0;i+j+k+m<101&&a[0]*i+a[1]*j+a[2]*k+a[3]*m<251;m++)
                    for(n=0;i+j+k+m+n<101&&a[0]*i+a[1]*j+a[2]*k+a[3]*m+a[4]*n<251;n++)
                        c[a[0]*i+a[1]*j+a[2]*k+a[3]*m+a[4]*n]+=1;
              
    while(scanf("%d",&cent)!=EOF)
    {
        printf("%d\n",c[cent]);
    }
return 0;
}

 

posted on 2012-04-22 17:22  Action!  阅读(703)  评论(0编辑  收藏  举报

导航