POJ 2482 Stars in Your Window

Stars in Your Window
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7250   Accepted: 1942

Description

Fleeting time does not blur my memory of you. Can it really be 4 years since I first saw you? I still remember, vividly, on the beautiful Zhuhai Campus, 4 years ago, from the moment I saw you smile, as you were walking out of the classroom and turned your head back, with the soft sunset glow shining on your rosy cheek, I knew, I knew that I was already drunk on you. Then, after several months’ observation and prying, your grace and your wisdom, your attitude to life and your aspiration for future were all strongly impressed on my memory. You were the glamorous and sunny girl whom I always dream of to share the rest of my life with. Alas, actually you were far beyond my wildest dreams and I had no idea about how to bridge that gulf between you and me. So I schemed nothing but to wait, to wait for an appropriate opportunity. Till now — the arrival of graduation, I realize I am such an idiot that one should create the opportunity and seize it instead of just waiting.

These days, having parted with friends, roommates and classmates one after another, I still cannot believe the fact that after waving hands, these familiar faces will soon vanish from our life and become no more than a memory. I will move out from school tomorrow. And you are planning to fly far far away, to pursue your future and fulfill your dreams. Perhaps we will not meet each other any more if without fate and luck. So tonight, I was wandering around your dormitory building hoping to meet you there by chance. But contradictorily, your appearance must quicken my heartbeat and my clumsy tongue might be not able to belch out a word. I cannot remember how many times I have passed your dormitory building both in Zhuhai and Guangzhou, and each time aspired to see you appear in the balcony or your silhouette that cast on the window. I cannot remember how many times this idea comes to my mind: call her out to have dinner or at least a conversation. But each time, thinking of your excellence and my commonness, the predominance of timidity over courage drove me leave silently.

Graduation, means the end of life in university, the end of these glorious, romantic years. Your lovely smile which is my original incentive to work hard and this unrequited love will be both sealed as a memory in the deep of my heart and my mind. Graduation, also means a start of new life, a footprint on the way to bright prospect. I truly hope you will be happy everyday abroad and everything goes well. Meanwhile, I will try to get out from puerility and become more sophisticated. To pursue my own love and happiness here in reality will be my ideal I never desert.

Farewell, my princess!

If someday, somewhere, we have a chance to gather, even as gray-haired man and woman, at that time, I hope we can be good friends to share this memory proudly to relight the youthful and joyful emotions. If this chance never comes, I wish I were the stars in the sky and twinkling in your window, to bless you far away, as friends, to accompany you every night, sharing the sweet dreams or going through the nightmares together.

Here comes the problem: Assume the sky is a flat plane. All the stars lie on it with a location (x, y). for each star, there is a grade ranging from 1 to 100, representing its brightness, where 100 is the brightest and 1 is the weakest. The window is a rectangle whose edges are parallel to the x-axis or y-axis. Your task is to tell where I should put the window in order to maximize the sum of the brightness of the stars within the window. Note, the stars which are right on the edge of the window does not count. The window can be translated but rotation is not allowed.

Input

There are several test cases in the input. The first line of each case contains 3 integers: n, W, H, indicating the number of stars, the horizontal length and the vertical height of the rectangle-shaped window. Then n lines follow, with 3 integers each: x, y, c, telling the location (x, y) and the brightness of each star. No two stars are on the same point.

There are at least 1 and at most 10000 stars in the sky. 1<=W,H<=1000000, 0<=x,y<2^31.

Output

For each test case, output the maximum brightness in a single line.

Sample Input

3 5 4
1 2 3
2 3 2
6 3 1
3 5 4
1 2 3
2 3 2
5 3 1

Sample Output

5
6

Source

POJ Contest,Author:kinfkong@ZSU
//这题的巧妙程度真的是让人敬佩思维力量的伟大呀
//开始听说要求线段覆盖次数,还有以某点为中心找最大覆盖面积
//那真的是云里雾里,还有黑书上的采矿题和这一样,方法我差不多明白,不过就是那个更新感觉实现不来
//这题的关键思路就是,将每个矩形当成点来处理、用左下角的那个点代表矩形,投影到y轴
//那么对于每个星星的纵坐标,y,y+h-1就是每个星星可以影响到的矩形
//然后x,x+w就是一个进入事件和一个出去事件,其所带的值互为相反数
//然后这题就华丽丽的转换成:求整段区间的最大值,然后就是成段更新

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
#include <algorithm>
#define lson l,m,k<<1
#define rson m+1,r,k<<1|1
#define N 10003
using namespace std;
struct node
{
    __int64 x,y,val;
    bool operator<(const node&b)const
    {
        if(x==b.x)
          return val<b.val;
        return x<b.x;
    }
};
struct tree
{
    __int64 Max,add;
};
node li[N<<1];
__int64 rcy[N];
tree st[N<<2];
void build(int l,int r,int k)
{
    st[k].Max=st[k].add=0;
    if(l==r)
      return ;
    int m=(l+r)>>1;
    build(lson);
    build(rson);
}
void down(int &k)
{
    st[k<<1].Max+=st[k].add;
    st[k<<1].add+=st[k].add;
    st[k<<1|1].Max+=st[k].add;
    st[k<<1|1].add+=st[k].add;
    st[k].add=0;
}
void up(int &k)
{
    st[k].Max=max(st[k<<1].Max,st[k<<1|1].Max);
}
__int64 add;
void update(__int64 &L,__int64 &R,int l,int r,int k)
{
      if(L<=rcy[l]&&R>=rcy[r])
      {
          st[k].Max+=add;
          st[k].add+=add;
          return ;
      }
      if(l==r)return;
      if(st[k].add)
       down(k);
      int m=(l+r)>>1;
      if(L<=rcy[m]) update(L,R,lson);
      if(R>rcy[m])  update(L,R,rson);
      up(k);
}
int main()
{
    int n;
    __int64 w,h;
    int i,k,j;
    __int64 ans;
    while(scanf("%d%I64d%I64d",&n,&w,&h)!=EOF)
    {
        for(i=0;i<n;i++)
        {
            scanf("%I64d%I64d%I64d",&li[i].x,&li[i].y,&li[i].val);
            j=i+n;
            rcy[i]=li[i].y;
            li[j].x=li[i].x+w;
            li[j].y=li[i].y;
            li[j].val=-li[i].val;
        }
       k=n<<1;
       sort(li,li+k);
       sort(rcy,rcy+n);
       for(j=0,i=1;i<n;i++)//开始忘记离散化了,、、、o(╯□╰)o
         if(rcy[i]!=rcy[j])
           rcy[++j]=rcy[i];
       n=j;ans=0;
       build(0,n,1);
       for(i=0;i<k;i++)
       {
         w=li[i].y+h-1;
         add=li[i].val;
         update(li[i].y,w,0,n,1);
         ans=ans>st[1].Max?ans:st[1].Max;
       }
       printf("%I64d\n",ans);
    }
    return 0;
}

posted on 2012-07-28 16:24  江财小子  阅读(420)  评论(0编辑  收藏  举报