关于asp.net利用mono部署到Linux上的一些说明

linuxdot.net社区群:102732979(如果你认为你已经在.NET跨平台方面有足够的经验,请参加这个群:103810355)。

其中有各种大神,嘿嘿,如果你有问题可以来咨询,完全无偿的免费的。

mono的发展越来越好,而转向linux.net的童鞋也越来越多,随之而来出现的问题也越来越多。

不过这些问题大多是环境配置问题,或者版本问题,这样导致群友们整天都在解决这些低级的问题,浪费了大家的时间。

故在此根据群内出现的问题和大家提出的解决方法做一些说明。

1、关于Linux群友用的最多的两个Server发行版

UbuntuCentOS,建议用稍微稳定的版本。

WebServer用的是jexus最新版,如果有更新的话,如果影响不大的话你就更新吧。(请注意备份)

2、在您安装mono和jexus前,请参照最新的技术文章首推linuxdot.net(宇内流云)、jexus.org(小白)、张善友小蝶惊鸿等人的博客文章。

必看的文章索引:http://www.cnblogs.com/shanyou/archive/2012/07/28/2612919.html

一定得确认版本:目前mono官网tar包有问题的版本是3.4,如果您需要最新的完整的tar包,请移步张善友博客或者群内共享文件。(下载地址

目前官方包能够使用的是3.2.8版本,github上的是3.6.1(截止至2014-06-24),想要安装最新的mono(3.6.1)的话,需要先安装mono3.2.8,安装时一定按照路径

./configure --prefix=/usr

这样除了能够系统自动识别so库之外,还有就是为了以后升级新版可以覆盖安装用。这是大家试过很多次给出的忠告。

以上网站不限于以上网站,有很多群友的希望补充

官方包有时时不时会抽风,少些文件什么的,建议安装前问问最稳定的版本。

jexus自动随开机启动最简单的方法(在 /etc/rc.local中加一句: /usr/jexus/jws start)

3、关于linuxdotnet够成熟吗

这个问题你得看看张善友的博客,他收集了很多关于mono的文章,至于生产环境,你来群里问问有多少人用就明白了,想用的总会有一种理由,不想用的总有千万个借口!是不是?

4、目前EntityFramework的 dbfirst(mysql)和codefirst(mysql)是可以的,但是一定得是版本EF6

关于这个鄙人弄了2-3篇文章测试了,可以看看,如果有问题可以大家一起讨论下。在使用mysql的时候大家也不必费劲下载那些dll了,

干脆直接就Nuget(这个如果还没用,请您抓紧时间!)吧

5、部署MVC程序

目前是MVC3及其以上可以部署,最快的方法是找群友要bin下的dll,文章看小蝶惊鸿的吧

6、关于(jexus)开源的话题

不想多说,只想说一句,免费用的商业软件,还提供部分技术支持。

7、如何解决问题

提问时,环境、版本等一定要提前说清楚,有助于解决问题。如果大家再花时间去问你系统环境和软件版本,是不是有点不划算?

遇到问题首先去以上网站去搜搜,请不要灰心,我们缺乏的是动手能力,试试你就知道了。

看清提示,提示上会说原因,虽然不全是对的,但最起码指明了方向,英文不好可以把错误信息粘出来,贴群里,或者自己bing。

8、愿望

如果你的问题是个新问题,本着人人为我,我为人人的想法,也请你在有时间的情况下,写篇文章出来,让遇到同样问题的朋友有个参考。

以上参考了宇内流云,小蝶惊鸿的建议,还有很多没有提到的群友,在这里大家可以留言我会补充。

此文会继续更新......

posted @ 2014-05-19 22:45 逆水寒龙 阅读(...) 评论(...) 编辑 收藏