扩大
缩小

HDUOJ1860 统计字符

统计字符

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5381    Accepted Submission(s): 3346


Problem Description
统计一个给定字符串中指定的字符出现的次数
 

 

Input
测试输入包含若干测试用例,每个测试用例包含2行,第1行为一个长度不超过5的字符串,第2行为一个长度不超过80的字符串。注意这里的字符串包含空格,即空格也可能是要求被统计的字符之一。当读到'#'时输入结束,相应的结果不要输出。
 

 

Output
对每个测试用例,统计第1行中字符串的每个字符在第2行字符串中出现的次数,按如下格式输出:
c0 n0
c1 n1
c2 n2
... 
其中ci是第1行中第i个字符,ni是ci出现的次数。
 

 

Sample Input
I THIS IS A TEST i ng this is a long test string #
 

 

Sample Output
I 2 i 3 5 n 2 g 2 注:第2个测试用例中,空格也是被统计的字符之一。
 
View Code
#include<stdio.h>
#include<string.h>
int main()
{
    int len1,len2;
    int i,j;
    int cnt;
    char str1[6],str2[100];
    while(gets(str1))
    {
       if(str1[0]=='#')
       break;
       gets(str2);
       len1=strlen(str1);
       len2=strlen(str2);
       for(i=0;i<len1;i++)
       {
          cnt=0;
         printf("%c ",str1[i]);
         for(j=0;j<len2;j++)
            if(str1[i]==str2[j])
               cnt++;
               printf("%d\n",cnt);
       }
    }
    return 0;
}

 

 

posted on 2012-07-27 22:31  LinuxPanda  阅读(282)  评论(0编辑  收藏  举报

导航